[Setup] Re: Migration from Plone 2.1.2. to Plone 2.5.3

Maurits van Rees m.van.rees at zestsoftware.nl
Tue May 29 21:18:29 UTC 2007


Zanotti Michele, on 2007-05-29:
> Thank you Alisa,
> excuse me but you mean I must install the old and the new versions of
> Zope/Plone on the same computer? The sentence "When you have both
> screens up on your computer, copy and paste" isn't very clear for me (my
> english is very bad, excuse me again!).

I must say I did not understand that remark either. :)

But your main error is this:

Error type: cPickle.PicklingError
Error value: Can't pickle <class 'App.Product.atoi'>: attribute lookup
App.Product.atoi failed


`Pickling` means storing something in the zope database.  And storing
a class in the database, which seems what is being tried here, indeed
does not make much sense.

So it looks like you have a product in your Products folder that is
behaving badly.  If you can, try searching for code in your Products
folder that contains a line with this text.

If that does not work, give us a list of the products that are in your
Products folder.

> Trying plone update from 2.1.2 to 2.5.3 (and from Zope 2.8.5 to Zope
> 2.8.9 on windows) i obtain this error:

You may want to try Zope 2.9.7, which is the recommended version.  The
release notes for Plone 2.5.3 say that it should work with zope 2.8.9
too though, if you have Five version 1.2.

Hm, which version of Five do you have?  Look in:
Products\Five\version.txt

-- 
Maurits van Rees | http://maurits.vanrees.org/ [NL]
            Work | http://zestsoftware.nl/
"Do not worry about your difficulties in computers,
 I can assure you mine are still greater."




More information about the Setup mailing list