[Setup] AttributeError: authenticate

mkaplan kaplan at ma.tum.de
Sat Jun 30 15:45:28 UTC 2007


I'm running Plone 2.1.3 with Zope 2.8.5 and only changed content for the
last few weeks. 
No updates, no new configuration. 

Today I tried to call Plone-Setup but got the KeyError :
'isDevelopmentMode'. Therefore I looked
at zope.conf and found that I forgot to switch off debug-mode when I worked
with Zope
the last time :(. 
I switched off debug-mode and restarted Zope.
Since then I cannot do anything with my site. Every call to a page leads to
the AttributeError: authenticate.  

Traceback (innermost last):

    * Module ZPublisher.Publish, line 187, in publish_module_standard
    * Module Products.PlacelessTranslationService.PatchStringIO, line 34, in
    * Module ZPublisher.Publish, line 144, in publish
    * Module Zope2.App.startup, line 216, in zpublisher_exception_hook
    * Module ZPublisher.Publish, line 104, in publish
    * Module ZPublisher.BaseRequest, line 445, in traverse
    * Module AccessControl.User, line 641, in validate
    * Module Products.GroupUserFolder.GroupUserFolder, line 1025, in

I recovered the state of my server from a week ago but nothing changed. 
Another Plone site on the same Zope still runs fine. 

Is there any workaround for this behaviour? 

Thanks in advance
View this message in context: http://www.nabble.com/AttributeError%3A-authenticate-tf4005208s15482.html#a11374658
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.

More information about the Setup mailing list