[Setup] ZMySQLDA With SuSE Plone

ThisGuyIKnow spomerg at cwu.EDU
Mon Jun 25 20:20:47 UTC 2007

I went ahead and uninstalled all the packages via rpm -e and removed the
leftover dirs. I then did a fresh install following your instructions plus
adding rpm -Uhv python24-mysql-1.2.2-1.i586.rpm just before installing the
zope rpm and rpm -Uhv just after installing the plone rpm and voila... not
only is everything copasetic now, but I now have "Z MySQL Database
Connection" in my dropdown Add menu.

Not sure what went wrong before. Weird.

Thanks for your help and bigger thanks for the extra rpm packages. Have a
great day.


rpm -V plone

tells you whether it still is installed correctly. To start over it is
best to uninstall Plone, remove the Zope instance, create a new one and
then install the Plone RPM again. Of course, uninstalling all related
packages (zope, python24, python24-*, zope-mysql) and removing the
remainder (/opt/zope, /var/opt/zope, /opt/python24) will make testing

I did (after I had emailed you) try to install python-mysql via:

   Edit site.cfg:
     mysql_config = /usr/bin/mysql_config
  /opt/python24/bin/python setup.py build
  /opt/python24/bin/python setup.py install --prefix=/opt/python24

I also downloaded and tried the non-SuSE ZMySQLDA with this and still no go.

Thinking I was still missing something, I tried out your rpm's. Thanks for
making these, that was thoughtful. However they still didn't work. My
install products page still didn't show the Zope MySQL Database Adapter.
Then I decided to uninstall the packages since they weren't working and now
my zope instance is broken. Don't worry, it's not a big deal since I'm doing
all this on a test server. :) When I browse to my Plone site I see:

  <PloneSite at broken>

I can however get to my Zope root and next to my instance it says:

  This object from the CMFPlone product is broken!
When clicking on this I get more info:

  This object is broken because the CMFPlone product that created it is no
longer installed or is installed incorrectly. Please
  contact the product maintainer for assistance.

  Note that the data associated with this product has not been lost, and
will be accessible again if the product is reinstalled.

I see that there are still files in
/var/opt/zope/default/Products/CMFPlone/, so I'm not sure what I can do to
make it "correctly installed" other than to start all over.

I'll keep hacking away at it. This is still fun for me. :D If you have any
ideas please feel free to send them my way. Happy to do some product testing
for you too! ;)

- Gavin

Markus Tesmer wrote:
> Hi Gavin,
> the Plone 2.5.3 RPM bundle contains its own Python version (2.4.4, not 
> contained in openSUSE 10.2). When you add Python functionality 
> like 'python-mysql' to your Plone installation you have to use this Python 
> version (cf. 
> http://www.remset.net/Members/Markus/download/plone-suse10-2/installation-instructions#AEN154 
> or the installation instructions) to install the modules.
> I have built the packages for you and put them at
> http://www.remset.net/Members/Markus/download/plone-suse10-2/rpms/mysqldb/
> Since I did not have the opportunity to test them I would be glad to hear
> if 
> they are working for you.
> Best wishes,
> Markus
> _______________________________________________
> Setup mailing list
> Setup at lists.plone.org
> http://lists.plone.org/mailman/listinfo/setup
View this message in context: http://www.nabble.com/ZMySQLDA-With-SuSE-Plone-tf3965778s15482.html#a11294793
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.

More information about the Setup mailing list