[Setup] LDAP issues (linux)

Chris Quenelle chris.quenelle at gmail.com
Fri Jul 27 05:11:21 UTC 2007

I'm trying to get basic LDAP auth working.  I can get the basic auth part
working.  But I have
two problems which are very annoying.

1. After adding any sort of LDAP auth (I tried two styles) the
object becomes nonfunctional (only Undo/Ownership/Interfaces tabs are
there anymore).
That means I can't control the search order of auth modules anymore, and I can't
deactive the plugin or select different kinds of LDAP integration
(groups, enumeration etc).

2. After adding LDAP auth, the zope/admin user is no longer recognized
by plone as
an 'admin' user.  So I have to define a 'ploneadmin' user, and assign
it manager privs
before adding the LDAP module.

Has anyone seen these issues before?  Here are my versions:

zope 2.96 (using ubuntu/debian package on linux)
plone 2.53 (tried package, and then tried download tarball)
LDAPMultiPlugin 1.5
LDAPUserFolder 2.8
GroupUserFolder 3.53.3

One more detail:  I have tried using LDAPMultiPlugin, and then I tried adapting
the GMail Auth module to use LDAP.  I got a working Product which authenticates
against LDAP the way I want, but it ALSO causes the missing 'plugins'
This happens even when LDAPMultiPlugin has been deleted.


More information about the Setup mailing list