[Setup] Re: Problem upgrading from 2.14 to 2.53: KeyError: _Real

Nick Davis nd51 at leicester.ac.uk
Thu Jul 26 11:19:11 UTC 2007


Dan Thomas wrote:
> I have tried repeatedly to upgrade a Plone site (2.14, Zope 2.87, Python 2.35,
> Windows XP) to Plone 2.52 or 2.53 running in a completely separate Zope
> installation, by dropping in Data.fs.
> 
> After migration attempt I get the error KeyError: '_real' (see traceback below).
> It also appears in the ZMI left-hand column!
> 
> Do I need to "clean" the Data.fs somehow? 
> 
> Thanks for any help.
> 
> Dan

Dan,
   Not sure when you mean this happened- during, or after, migration 
attempt. If the migration itself failed, all bets are off about what 
will get served when attempting to look at the site AFTER that.

To make progress here's some ideas:

Before attempting portal_migration, make sure nothing is broken in ZMI.

Are all 3rd-party products in the new site compatible with Plone 2.5.3? 
Get the new versions if required, before attempting migration.

Before attempting portal_migration make sure you don't have "rogue 
customisations" floating around. Any customised versions of old versions 
of templates,scripts etc can cause problems, so you have to compare 
everything you've customised and re-apply customisations where 
necessary. This kind of audit is essential when migrating.

As for "cleaning the Data.fs", well you could first do a catalog clear 
and rebuild from ZMI->portal_catalog->Advanced. This wouldn't hurt, and 
while it takes a while to run, helps in certain circumstances.

Regards,
Nick


-- 
Nick Davis
Web Application Developer
University of Leicester
http://www2.le.ac.uk




More information about the Setup mailing list