[Setup] Re: Upgrading Plone to ver 2.5.2

J Cameron Cooper jccooper at rice.edu
Tue Jul 24 15:16:32 UTC 2007


Lerato wrote:
> Plone 2.5.2 comes with Zope 2.9 on it. so Zope is fine.

But are you certain that your instance is running on the new Zope? This 
is an error indicative of running on an old Zope.

"Installing on top of" is not the recommended (and not the supported) 
way of upgrading Plone. Rather, install alongside and copy data (and 
non-default products) over.

        --jcc


> Nick Davis-3 wrote:
>> Lerato wrote:
>>> I backed up my old Plone
>>> Shut down Plone server instance
>>> Installed Plone 2.5.2 on top of Plone 2.1.2
>>>  
>>> and i get the following erroe below the installation could finish
>>> please help help help
>>>
>>> Executing the command 'setupSite.py' failed
>>> ImportError: No  module named zope.interface.
>>>
>>> Please help as i need to move from Plone 2.1.2 to 2.5.2
>> Lerato,
>> Maybe you need to upgrade Zope as well? check 2.5.2 release notes 
>> against your zope version.
>> Regards,
>> Nick


-- 
Connexions
http://cnx.org

"Building Websites with Plone"
http://plonebook.packtpub.com




More information about the Setup mailing list