[Setup] Re: Accent on Plone with ldap problem

Niels Steen Krogh nielssteenkrogh at zitelab.dk
Wed Jan 17 11:06:41 UTC 2007


I have no ldap-experience, but usually ascii-encoding problems are solved
using script like this if its python-related:
# sitecustomize.py                   1
# this file can be anywhere in your Python path,
# but it usually goes in ${pythondir}/lib/site-packages/

import sys

sys.setdefaultencoding('utf-8')
/Niels

> 
>    1. accent on Plone with ldap problem (Juan Elias)

> Message: 1
> Date: Tue, 16 Jan 2007 17:38:17 -0300
> From: "Juan Elias" <pichoelias at gmail.com>
> Subject: [Setup] accent on Plone with ldap problem
> To: Setup at lists.plone.org
> Message-ID:
> 	<607e01140701161238h5669cb6do8d31b33028c6d6ad at mail.gmail.com>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Hi, we are trying to use accent on Plone 2.5 with Ldap (patched with 
> ldap multipugin patched v 1.4), but we have the next problem
> 
> Traceback (innermost last):
>   Module ZPublisher.Publish, line 115, in publish
>   Module ZPublisher.mapply, line 88, in mapply
>   Module ZPublisher.Publish, line 41, in call_object
>   Module Products.CMFFormController.ControllerPageTemplate, line 80, 
> in __call__  Module 
> Products.CMFFormController.BaseControllerPageTemplate, line 39, in _call
>   Module Products.CMFFormController.ControllerBase, line 245, in getNext
>    - __traceback_info__: ['id = join_form', 'status = success',
> 'button=Register', 'errors={}', 'context=<PloneSite at penalolen>',
> 'kwargs={}', 'next_action=None', '']
>   Module Products.CMFFormController.Actions.TraverseTo, line 36, in __call__
>   Module ZPublisher.mapply, line 88, in mapply
>   Module ZPublisher.Publish, line 41, in call_object
>   Module Products.CMFFormController.FSControllerPythonScript, line 
> 108, in __call__  Module Products.CMFFormController.Script, line 141,
>  in __call__  Module Products.CMFCore.FSPythonScript, line 108, in __call__
>   Module Shared.DC.Scripts.Bindings, line 311, in __call__
>   Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
>   Module Products.CMFCore.FSPythonScript, line 164, in _exec
>   Module None, line 19, in register
>    - <FSControllerPythonScript at /penalolen/register>
>    - Line 19
>   Module Products.CMFCore.RegistrationTool, line 158, in addMember
>   Module Products.PlonePAS.tools.membership, line 66, in addMember
>   Module Products.PlonePAS.tools.memberdata, line 155, in
> setMemberProperties
>   Module Products.LDAPMultiPlugins.property, line 37, in setProperty
>   Module Products.LDAPMultiPlugins.property, line 48, in 
> setProperties UnicodeDecodeError: 'ascii' codec can't decode byte 
> 0xc3 in position 15: ordinal not in range(128)
> 
> can help me to solve the problem?
> 
> thnxs
> -- 
> Juan Elias
> -- 
> Juan Elias
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:
http://lists.plone.org/pipermail/setup/attachments/20070116/8d62f917/attachment.html
> 
> ------------------------------
> 





More information about the Setup mailing list