[Setup] MySQL database having userfields deleted on updates

garyk garyk at skilltran.net
Thu Dec 20 23:18:29 UTC 2007


Hi All,

I installed SQLPASPlugin and configured a MySQL database to work with it. 
The database accepts updates, Plone reads roles and sets permissions for the
users just fine from it, but when I update a user's role from within User
and Group Administration it is dropping the data in the password and email
fields in the database.  

Looking at /portal_skins/plone_prefs/user_prefs_manage and the actual sql
queries that Plone uses to communicate with the database inside acl_users it
looks as if it's possible that this behavior could be coming from either
place, or a combination of the two as the update sql queries use insert
statements and user_prefs_manage script sets user attributes to equal member
attributes and I don't know if Plone is still storing, or looking, in the
ZODB on these updates.  Or, there is a third option, and that's that my
suppositions are completely wrong.   

I'm having trouble just finding what does what as I'm so new to both Zope
and Plone so I could easily be missing some important aspect of this.  
Could someone either point me to documentation on this or educate me a
little here?  I'd sure appreciate it.  

TIA,

Gary
-- 
View this message in context: http://www.nabble.com/MySQL-database-having-userfields-deleted-on-updates-tp14447230s15482p14447230.html
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.




More information about the Setup mailing list