[Setup] fresh 3.0.3 unified install problems

bwirtz bwirtz at gmail.com
Wed Dec 5 20:12:42 UTC 2007

I've been unable to get a Plone install completely running.  The install
seems to go fine, but I get into trouble when I try to start it up.  Here
are the details.

The big picture.
Unable to open port after a fresh install.

A snapshot of your environment.
My OS is debian/testing.
I downloaded the 3.0.3 unified installer yesterday, and the installation ran
through fine.

Steps to reproduce the error.
1.  Install using the unified installer
2.  Start plone via "sudo /opt/Plone-3.0.3/zinstance/bin/zopectl start"
3.  Point a web browser to port 8080(or whatever the configured port is - I
tried several just to be certain)

The expected result.
I'd get the main zope page
The actual result.
I get a "connection reset" error.

When I ran top, I noticed that python was completely utilizing the processor
& the process number changed every 5 seconds or so.  When I ran "ps aux |
grep <process_id", I found this:

plone    24519 98.1  6.2  36516 32048 ?        R    07:04   0:08
/opt/Plone-3.0.3/lib/python/Zope2/Startup/run.py -C

So I decide to try and run that command at my shell prompt directly to see
what's going on.  Here are the results of that:

bryon at jekyll:~$ /opt/Plone-3.0.3/Python-2.4.4/bin/python
/opt/Plone-3.0.3/lib/python/Zope2/Startup/run.py -C
Traceback (most recent call last):
  File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/run.py", line 56, in ?
  File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/run.py", line 21, in run
  File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/__init__.py", line 96, in
  File "/opt/Plone-3.0.3/lib/python/Zope2/Startup/__init__.py", line 229, in
    raise ZConfig.ConfigurationError(socket_err
ZConfig.ConfigurationError: There was a problem starting a server of type
"HTTPServer". This may mean that your user does not have permission to bind
to the port which the server is trying to use or the port may already be in
use by another application. (Address already in use)

This happens no matter what port I have configured in my
/opt/Plone-3.0.3/zinstance/etc/zope.conf file.  Currently, it looks like
  # valid keys are "address" and "force-connection-close"
  address 8090
  # force-connection-close on
  # You can also use the WSGI interface between ZServer and ZPublisher:
  # use-wsgi on

Thank you for any help you can give me.


View this message in context: http://www.nabble.com/fresh-3.0.3-unified-install-problems-tf4951651s15482.html#a14178235
Sent from the Installation, Setup, Upgrades mailing list archive at Nabble.com.

More information about the Setup mailing list