[Setup] Problem importing site from 2.1.2 to 2.5 on different server.

frankbenjones at aim.com frankbenjones at aim.com
Sun Nov 26 07:10:03 UTC 2006


 (Just noticed I originally posted to the users list instead of setup list by mistake. Sorry for the double post).
 
 I'm trying to upgrade two Plone sites from 2.1.2 to 2.5 or 2.5.1. I get the following error when importing the exported plone site zexp file:
 
 ----------------------------------------------------------------------------------------------------------
 Site Error
 An error was encountered while publishing this resource. 
 
 Error Type: TransformException
 Error Value: Output MIME type 'image/pcx' for transform image_to_pcx is not registered in the MIME types registry
 ----------------------------------------------------------------------------------------------------------
 
 Log output below (from the windows box):
 
 2006-11-25T22:40:30 ERROR Zope.SiteErrorLog http://localhost:8080/test/manage_importObject
 Traceback (most recent call last):
 File "C:\Program Files\Plone 2\Zope\lib\python\ZPublisher\Publish.py", line 114, in publish
 request, bind=1)
 File "C:\Program Files\Plone 2\Zope\lib\python\ZPublisher\mapply.py", line 88, in mapply
 if debug is not None: return debug(object,args,context)
 File "C:\Program Files\Plone 2\Zope\lib\python\ZPublisher\Publish.py", line 40, in call_object
 result=apply(object,args) # Type s<cr> to step into published object.
 File "C:\Program Files\Plone 2\Zope\lib\python\OFS\ObjectManager.py", line 577, in manage_importObject
 set_owner=set_owner)
 File "C:\Program Files\Plone 2\Zope\lib\python\OFS\ObjectManager.py", line 599, in _importObjectFromFile
 self._setObject(id, ob, set_owner=set_owner)
 File "C:\Program Files\Plone 2\Zope\lib\python\OFS\ObjectManager.py", line 309, in _setObject
 object.manage_afterAdd(object, self)
 File "C:\Program Files\Plone 2\Data\Products\CMFCore\CMFCatalogAware.py", line 203, in manage_afterAdd
 self.__recurse('manage_afterAdd', item, container)
 File "C:\Program Files\Plone 2\Data\Products\CMFCore\CMFCatalogAware.py", line 239, in __recurse
 getattr(ob, name)(*args)
 File "C:\Program Files\Plone 2\Data\Products\PortalTransforms\TransformEngine.py", line 379, in manage_afterAdd
 transforms.initialize(self)
 File "C:\Program Files\Plone 2\Data\Products\PortalTransforms\transforms\__init__.py", line 60, in initialize
 engine.registerTransform(transform)
 File "C:\Program Files\Plone 2\Data\Products\PortalTransforms\TransformEngine.py", line 481, in registerTransform
 self._mapTransform(transform)
 File "C:\Program Files\Plone 2\Data\Products\PortalTransforms\TransformEngine.py", line 284, in _mapTransform
 raise TransformException(msg)
 TransformException: Output MIME type 'image/pcx' for transform image_to_pcx is not registered in the MIME types registry
 
 Same error trying to import another site on the Linux box. Here is the log for that import:
 
 2006-11-25T21:08:43 ERROR Zope.SiteErrorLog http://drogo.jonesns.net:8080/wcs/manage_importObject
 Traceback (innermost last):
 Module ZPublisher.Publish, line 115, in publish
 Module ZPublisher.mapply, line 88, in mapply
 Module ZPublisher.Publish, line 41, in call_object
 Module OFS.ObjectManager, line 588, in manage_importObject
 Module OFS.ObjectManager, line 610, in _importObjectFromFile
 Module OFS.ObjectManager, line 333, in _setObject
 Module zope.event, line 23, in notify
 Module zope.app.event.dispatching, line 66, in dispatch
 Module zope.component, line 181, in subscribers
 Module zope.component.site, line 89, in subscribers
 Module zope.interface.adapter, line 481, in subscribers
 Module zope.app.event.objectevent, line 192, in objectEventNotify
 Module zope.component, line 181, in subscribers
 Module zope.component.site, line 89, in subscribers
 Module zope.interface.adapter, line 481, in subscribers
 Module OFS.subscribers, line 114, in dispatchObjectMovedEvent
 Module OFS.subscribers, line 137, in callManageAfterAdd
 Module Products.CMFCore.CMFCatalogAware, line 203, in manage_afterAdd
 Module Products.CMFCore.CMFCatalogAware, line 239, in __recurse
 Module Products.PortalTransforms.TransformEngine, line 379, in manage_afterAdd
 Module Products.PortalTransforms.transforms, line 60, in initialize
 Module Products.PortalTransforms.TransformEngine, line 481, in registerTransform
 - __traceback_info__: ('image_to_pcx', <Transform at image_to_pcx>)
 Module Products.PortalTransforms.TransformEngine, line 284, in _mapTransform
 TransformException: Output MIME type 'image/pcx' for transform image_to_pcx is not registered in the MIME types registry
 
 In an attempt to fix this I installed 2.1.3 with the installer in 2003 Server thinking that going from 2.1.2 to 2.1.3 then to 2.1.4 and so on would fix this. Imported and migrated the site from 2.1.2, packed the database then exported it. I then installed 2.1.4 in another 2003 Server box (using vmware) and the did the migrations and database pack. Worked fine in both cases. I then installed 2.5.1 in another vmware clone and get the same error as I get with 2.5.1 in a CentOS 4.4 (fully updated) box installed with the "Universal" installer. I'm experiening this on both a 2003 Server where I installed with the 2.5.1 installer and on the CentOS box.
 
 I've searched on google, the plone site, and the user list but I must be an idiot as I can't find a solution.
 
 Any help would be appreciated as I'm clueless as to how to fix it.
 
 fj 
________________________________________________________________________
Check Out the new free AIM(R) Mail -- 2 GB of storage and industry-leading spam and email virus protection.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-setup/attachments/20061126/ae62f09f/attachment-0002.html>


More information about the Setup mailing list