[Setup] Trying to export from Plone 2.1.3 and import to 2.5.1

Mike Stawchansky mstawchansky at pathfire.com
Wed Nov 15 15:25:09 UTC 2006


I think I've installed all the correct Products into my Plone 2.5.1
instance to match the 2.1.3 I'm exporting from, however when I try to
import my .zexp of my 2.1.3 instance, it doesn't like me. Below is the
trace info, if anything jumps out your thoughs would be most
appreciated, or if I need to go about this a different way....
 
Thanks,
 
Mike
 
 
Traceback (innermost last):
  Module ZPublisher.Publish, line 115, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 41, in call_object
  Module OFS.ObjectManager, line 588, in manage_importObject
  Module OFS.ObjectManager, line 605, in _importObjectFromFile
  Module ZODB.ExportImport, line 75, in importFile
  Module transaction._transaction, line 295, in savepoint
  Module transaction._transaction, line 292, in savepoint
  Module transaction._transaction, line 675, in __init__
  Module ZODB.Connection, line 1012, in savepoint
  Module ZODB.Connection, line 493, in _commit
  Module ZODB.ExportImport, line 144, in _importDuringCommit
  Module copy_reg, line 48, in _reconstructor
TypeError: ('object.__new__(Index) is not safe, use
Persistence.Persistent.__new__()', <function _reconstructor at
0xb7f33dbc>, (<class 'textindexng.index.Index'>, <type 'object

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-setup/attachments/20061115/4c1dcffd/attachment-0001.html>


More information about the Setup mailing list