[Setup] Migration Plone 2.1.4 to Plone 2.5.1

Marc Van Coillie marc.van.coillie at eife-l.org
Tue Nov 14 08:31:57 UTC 2006


Hi,
I've reached to do the migration (my error was due to some specific 
properties in my portal_memberdata).
FYI, it seems that for Plone2.5/PlonePAS migration/installation :
- an empty (null) memberdata property can't work with it (so in that case 
use a default value in the portal_memberdata property seems to solve this)
- the same with a 'multipleselection' property (the only way I've found is 
to delete this property before to run the migration)

Anyway after my migration I've seen that the ACL_Users referenced all my 
previous users but the portal_memberdata section claims that there is no 
member stored in my site, is it normal ???
It seems not cause when I try to login I've got this error message:

Type de l'erreur
  TypeError
  Valeur de l'erreur
  iteration over non-sequence
  Requête envoyée au serveur le
  2006/11/14 08:12:51.483 GMT+1
Any ideas ?

Will it be better to install PlonePas 1.3 in my existing Plone2.1 portal and 
after that doing the migration to Plone 2.5 ???
Does anyone have tried this (migration from PlonePas1.3 to PlonePas 2) ?

Thanks in advance for your help,
Marc


Message: 3
Date: Sun, 12 Nov 2006 08:56:58 -0800
From: aaron <aaron at netcorps.org>
Subject: Re: [Setup] Migration Plone 2.1.4 to Plone 2.5.1
To: setup at lists.plone.org
Message-ID: <AF32191D-67F3-4F44-835D-8D04DE5C7163 at netcorps.org>
Content-Type: text/plain; charset=US-ASCII; delsp=yes; format=flowed

Marc,
I  have had success migrating 2.1.4->2.5.1 by doing a forced
migration from 2.1 -> 2.5.1.  That seemed to solve it. Hope that helps.
Aaron 





More information about the Setup mailing list