[Setup] Re: Trouble with site rebuild after Data.fs replace

Nick Davis nd51 at le.ac.uk
Wed Nov 8 10:45:24 UTC 2006

Neal Legler wrote:

> But upon moving over the old Data.fs file we had copied prior to the 
> rebuild, suddenly the site, the ZMI, everything, is inaccessible. The 
> browser (Firefox) just gets stuck in perpetual waiting mode. We thought 
> maybe passwords were getting crossed, so we tried setting the password to 
> what it had been prior to the rebuild before moving the Data.fs file. Still 
> no luck.
> Our server is running Fedora Core 5 Linux. Strangely, when we attempted the 
> same operation on a Windows-based installation of Plone 2.5.1 (the latest 
> release), it worked ... mostly. We can access the Plone site, but can't 
> access the Zope root or ACL users without getting an error:

> Any ideas about how to get either our Linux-based site to load or our 
> Windows-based version to run error free would be most appreciated!

I will fire a few questions at you to try to help solve this. ;-)

Very obvious but, are you absolutely sure that in addition to Plone, 
your Linux box has the same version of Zope and Python that it had before?
And python libraries like PIL etc?
Any other tweaking, configuration you did that you may have forgotten to 
re-apply? did you make changes in zope.conf before?

How do the versions of python/zope/Plone on Windows and Linux compare. 
Absolutely the same?? Same zope.conf settings?

On the Linux box, without copying the Data.fs, if you create a fresh 
Plone site through the ZMI, then play around with that site, add content 
etc, is everything working OK?

Obvious again, but presumably you're looking thoroughly in event.log to 
see if Zope is saying anything at all just prior to locking up....
(you've got logging cranked up in zope.conf, right?)

This may or may not be revealing ,but can you get into your Linux Zope 
instance using zopectl debug? Once in, can you look around the site - 
app.<plone-root> etc - does the site look intact or is something 
obviously broken?

Useful info at:

(or Google for debug zope and/or debug plone, well worth learning these 
tricks which are great time-savers )

When you say your server was hacked, do you mean your Plone site or the 
machine in general? If its a spam attack, perhaps the rogue content 
added in the Plone site could have broken it (I don't know how or why, 
this is probably unlikely but doesn't hurt to eliminate the 
possibility). In that case you might use zopectl debug to do an audit of 
the site by hand and delete offending content. Or do it through Plone on 
the Windows box.

Here's another link, found by googling "debug spinning zope" :


Hope (some of) this points you in the right direction.


Nick Davis
Web Application Developer
University of Leicester

More information about the Setup mailing list