[Setup] Trouble with site rebuild after Data.fs replace

Neal Legler leglernc at yahoo.com
Wed Nov 8 01:56:19 UTC 2006


Hello!

Our server was recently hacked into, requiring a complete rebuild of 
everything. To rebuild our Plone site, we installed Plone using the same 
build we had used previously (2.5, rc2), then copied all of our products 
over. So far, so good.

But upon moving over the old Data.fs file we had copied prior to the 
rebuild, suddenly the site, the ZMI, everything, is inaccessible. The 
browser (Firefox) just gets stuck in perpetual waiting mode. We thought 
maybe passwords were getting crossed, so we tried setting the password to 
what it had been prior to the rebuild before moving the Data.fs file. Still 
no luck.

Our server is running Fedora Core 5 Linux. Strangely, when we attempted the 
same operation on a Windows-based installation of Plone 2.5.1 (the latest 
release), it worked ... mostly. We can access the Plone site, but can't 
access the Zope root or ACL users without getting an error:

Type: NameError
Value: name 'getDefaultSorting' is not defined

Here is the traceback:

2006-11-07T18:43:56 ERROR Zope.SiteErrorLog http://localhost/manage_main
Traceback (innermost last):
  Module ZPublisher.Publish, line 115, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 41, in call_object
  Module Shared.DC.Scripts.Bindings, line 311, in __call__
  Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
  Module App.special_dtml, line 176, in _exec
  Module DocumentTemplate.DT_Let, line 76, in render
  Module DocumentTemplate.DT_Util, line 196, in eval
   - __traceback_info__: REQUEST
  Module <string>, line 0, in ?
NameError: name 'getDefaultSorting' is not defined

Any ideas about how to get either our Linux-based site to load or our 
Windows-based version to run error free would be most appreciated!

Thank you!
Neal







More information about the Setup mailing list