[Setup] Problems with SessionCrumbler with Plone2.5

Paul Stiverson paul at math.tamu.edu
Wed Jul 19 18:01:08 UTC 2006


Howdy,

First of all I used the "UnifiedInstaller-r2" to install Plone2.5, since 
installation I have set up LDAP Authication according to the "Plone 2.5 
and OpenLDAP Integration ..." how-to. 

The problem I'm having is that I don't want our LDAP passwords being sent 
over the wire unencrypted, as such I tried using the "Secure login without 
plain text passwords" how-to, and it didn't work.  I couldn't 
locate any object with the ID "cookie_authentication", the closest I could 
find was "credentials_cookie_auth" in the "acl_users" directory.  Thinking 
this might have been the object the how-to was referring to (I founded 
this belief by looking in the "CMFPlone/skins/plone_login/login_form.cpt" 
file and seeing "auth nocall:here//credentials_cookie_auth|nothing" 
similar to what is described in the how-to) I replaced it with a 
"Session Auth Helper" object.  I set the activations similar to the 
previous object and recieved an error upon (attempted) login (as admin), 
the error follows:

Error Type
   AttributeError

Error Value
   login

Request made at
   [date and time]

It appeared that I had logged in, as the bar showed my username however I 
could not accomplish any actions.  When I tried to log in as an LDAP user 
it would not authenticate at all.

Any suggestions?  I'm very new to Plone, so I apologize if I sound as 
such.

Thanks
-paul





More information about the Setup mailing list