[Setup] trouble over-installing Plone2.5 on OS X 10.4

kamalgill at mac.com kamalgill at mac.com
Tue Jul 11 16:14:52 UTC 2006


Hi Dan,

A few questions to help troubleshoot the problem.

1) Was Plone shut down before the folders you listed below were removed?

2) Did you use the Plone installer with the Zope Hotfix, posted at plone.org after July 10?

3) Were the following items removed before re-installing Plone?
   - /opt/Plone-2.5 folder
   - /Library/Receipts/Plone-2.5.pkg
   - /Library/StartupItems/Plone-2.5-StartupItem.pkg

4) Did you select the startup item during a custom install?  If so, here's a possible scenario...Decide to re-install Plone...Restart computer...(Plone is now running due to startup item)...Trash Plone folders...reinstall Plone...(old Plone site still running due to startup item)...startup new Plone site...Admin password of new site doesn't work, as old site is still running, preventing the new site from starting up.

A quick test to determine whether Plone starts up properly is to use zopectl fg (fg = foreground), which will report any errors on startup.

HTH,
Kamal
 
On Monday, July 10, 2006, at 06:56PM, Dan LaSota <dan at ae-data.com> wrote:

>Hi,
>
>I ran into trouble with a Plone site I had successfully installed 
>from the binary for Mac OS X 10.4 (PPC). At some point I decided it 
>was easier to start over rather than fix an error I had made, so I 
>trashed these directories:
>
>/opt/Plone2.5
>/Library/StartupItems/Plone2
>/Library/Receipts/Plone*
>
>I went ahead and reinstalled the Plone package using the same binary 
>installer and it reported sucess.
>
>The problem is that the page delivered at
>
>http://host:8080/Plone serves up an error page, rather than the "You 
>have successfully installed Plone" page.
>
>It is thus:
>---
>Site Error
>An error was encountered while publishing this resource.
>Resource not found
>Sorry, the requested resource does not exist.
>Check the URL and try again.
>Resource: Plone GET
>
>Troubleshooting Suggestions
>	*	The URL may be incorrect.
>	*	The parameters passed to this resource may be incorrect.
>	*	A resource that this resource relies on may be 
>encountering an error.
>For more detailed information about the error, please refer to error log.
>If the error persists please contact the site maintainer. Thank you 
>for your patience.
>---
>
>The Zope page at http://host:8080 looks normal, but I cannot login to 
>the ZMI using the admin password at 
>/opt/Plone2.5/Instance/adminPassword.txt
>
>I have googled a bit and tried using the zpasswd.py script to install 
>a temporary user, but at this point I would like to know how to scrub 
>my system of Plone, and do a fresh install, short of actually 
>reformatting the drive and the system.
>
>Any pointers would be appreciated.
>
>Thanks,
>
>-- 
>Dan LaSota
>AE data, Inc.
>693 Manchester Loop
>Fairbanks, AK 99712
>(907) 479-0700
>dan at ae-data.com
>http://www.ae-data.com
>
>_______________________________________________
>Setup mailing list
>Setup at lists.plone.org
>http://lists.plone.org/mailman/listinfo/setup
>
>




More information about the Setup mailing list