[Setup] Re: problems with Members folder after a 2.0.5 -> 2.1.3 migration

Zhelia zhelia at free.fr
Fri Jul 7 15:03:39 UTC 2006


Nick Davis a écrit :
> Zhelia wrote:
>
>> After a "successfull" migration, the "view", "edit" or "see 
>> properties" actions on Members'folder throw errors (see the 
>> tracebacks below).
>> This looks like an "old" bug (http://dev.plone.org/plone/ticket/5089) 
>> Does Members folder really migrate correctly ? Some informations :
>>
>> - Before and after migration Members'folder has a "Large Plone 
>> Folder" metatype, and a "Folder" type
>>
>> - Members'folder isn't listed in the archetype tools 's catalog (so 
>> it hasn't an UID)
>>
>> - If I modify the aliases of the "FOLDER" type (and not those of 
>> "Large Plone Folder" type) in the portal type, replacing "dynamic 
>> view" and "atct_edit" by folder_listing or folder_contents and 
>> "folder edit form" , it works.
>>
>> I have follow the advices of Alec Mitchell on SF (update 
>> portal_catalog, atct_portal/recatalog, atct_portal/type Migration/fix 
>> portal type name and migrate) without success (but all seems to go 
>> well).
>> I would like to apply the Raphael Ritz 's code but ... hmm ... well, 
>> i'm  afraid to say that I don't know how to do exactly ...
>>
>> Thanks for your help,
>>
>> regards,
>>
>> Chloé
>>
>
> Hello Chloe,
>   Folders failing to convert to ATCT during migration, have 
> historically been caused by a missing 'portal_type'. If your site was 
> in the past a 2.0.RCx version of Plone for example, bugs in those 
> early releases could leave portal_type missing.
>   If you go to the ZMI, to portal_atct, then to type_migration and 
> scroll down there is a button marked "Fix missing portal type". Try in 
> your 2.0.5 site clicking this button before you start migration. Then 
> do all the other steps as you did before. I cannot promise but this 
> might fix it.
>   Even if you think its unlikely you're missing portal_type, it would 
> help to try this and at least eliminate the possibility.
> Regards
> Nick
>
Hello Nick,

Thanks for your answer :-)
I've applied again the procedure this morning before migration but 
unfortunately with the same result as the previous times (I 've hoped to 
have made errors before).
Concerning the initial version of Plone, it might help you to know that 
it's a 2.0.5 one (not a RC, according to the ZMI informations and the 
Plone tarball name).

In addition, I 've tried to test also this morning the code you were 
talking about with Raphael Ritz in the old posts I quoted above ... 
again without success but I'm absolutely not sure to do the things 
correctly :

- I edit a file and only put (Do I must add something ?)
site = app['myIdSite']
tt = site['portal_types']
tt['Large Plone Folder']._finishConstruction(site.Members)

- I restore my old datafs, and keep the Plone 2-1-3's products
- I start, go to quickinstaller to install Archetypes, ATContent and 
portal_transforms
- I stop and launch zopectl run "myFile"
- I start, I recatalog CMF, I update the atct version, then go to 
migration Type to fix name, type and migrate
- [and site migration]

... and ... I don't have an ATBTreeFolder and the error is still there :-(

I 'm probably not doing what it is necessary ... isnt it ?

Tanks again for your help and sorry for my bad english (don't hesitate 
to ask me to reformulate when it's not understandable),

regards,

Chloé











More information about the Setup mailing list