[Setup] Re: Is it OK to have Members folder type ATFolder not ATBTreeFolder in Plone 2.1.2?

Harri Alstelain harri.alstelain at hotmail.com.invalid
Tue Jan 31 17:50:36 UTC 2006


Tue, 31 Jan 2006 17:05:53 +0000, Nick Davis kirjoitti:
> Try looking at all these :
> can you get to mysite.portal_types  ?

In ZMI at http://localhost:8282/sitename/manage/
and selecting portal_types from the left I see: 

Plone Types Tool at /sitename/portal_types
   Discussion Item
   Document
   Event
   Favorite
   File
   Folder
   Image
   Link
   News Item
   Plone Site
   PloneChat
   TempFolder
   Topic

Should I also have "Large Plone Folder" listed here? 


> can you get to mysite.portal_types['Large Plone Folder']!

Where? How? Doesn't look like URL to me :-) 


> Now if there really is no ['Large Plone Folder'] in your portal_types,
> thats weird, and possibly the cause of your problem. 

I run several sites, oldest of them come originally from "Plone 0.X beta".
Maybe there has been an error in some older migration. In what version was
"Large Plone Folder" introduced? 

If I only have "Folder" I guess I need a way to convert "Members Folder"
   "Folder" -> "Large Plone Folder" 

Or will it be easier to fix that in 2.1.2 by somehow converting 
   "ATFolder" -> "ATBTreeFolder"? 

When I select "Members" in ZMI using Plone 2.0.5 I see:
   "Plone Folder at /sitename/Members"
After migration to 2.1.2 it is: 
   "ATFolder at /sitename/Members/"

According to some other posts I'm not the only one who has this problem...


Harri 





More information about the Setup mailing list