[Setup] Re: AttributeError: translation_service 2.0.4 to 2.1.1

Nick Davis nd51 at le.ac.uk
Mon Jan 30 11:54:55 UTC 2006


S
> 
> Migration can obviously not fix your customized templates. You will  
> have to review your customizations and adapt them to the Plone 2.1 way.
> 

And there is info on how to do that at the bottom of :

http://plone.org/documentation/migration/2.1


BTW it seems to me everyone should have customisations in their own 
filesystem-based product.

That makes it easy to:

1) diff between Plone 2.1.x templates and Plone 2.0.x templates to see 
if anything actually changed and you need to rea-pply changes.

2) For ones that did change, diff between customised template and 
original Plone 2.0.x template to remind yourself what exactly you hacked.

3) re-apply changes to just the templates that you originally changed.


Perhaps there should be some kind of ceremonial tearing out and burning 
of the sections of Zope/Plone books that explain to people how to 
customise through the filesystem.  ;-)


Nick




More information about the Setup mailing list