[Setup] Re: Plone security help

François-Régis Chalaoux chalaouxfr at gmail.com
Tue Jan 17 10:03:48 UTC 2006


I forgot to give you my error message when I abort to fill the
authenfication dialog :


Site Error

An error was encountered while publishing this resource.

*Unauthorized*
Sorry, a site error occurred.

Traceback (innermost last):

   - Module ZPublisher.Publish, line 187, in publish_module_standard
   - Module Products.PlacelessTranslationService.PatchStringIO, line 51,
   in new_publish
   - Module ZPublisher.Publish, line 144, in publish
   - Module Zope2.App.startup, line 199, in zpublisher_exception_hook
   - Module ZPublisher.Publish, line 113, in publish
   - Module ZPublisher.mapply, line 88, in mapply
   - Module ZPublisher.Publish, line 40, in call_object
   - Module Shared.DC.Scripts.Bindings, line 311, in __call__
   - Module Shared.DC.Scripts.Bindings, line 329, in _bindAndExec
   - Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
   - Module Products.CMFCore.FSPageTemplate, line 195, in _exec
   - Module Products.CMFCore.FSPageTemplate, line 134, in pt_render
   - Module Products.PageTemplates.PageTemplate, line 104, in pt_render
   *<FSPageTemplate at /copy_of_bioinfo/insufficient_privileges>*
   - Module TAL.TALInterpreter, line 202, in __call__
   - Module TAL.TALInterpreter, line 206, in __call__
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 711, in do_useMacro
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 426, in do_optTag_tal
   - Module TAL.TALInterpreter, line 411, in do_optTag
   - Module TAL.TALInterpreter, line 406, in no_tag
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 711, in do_useMacro
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 677, in do_condition
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 426, in do_optTag_tal
   - Module TAL.TALInterpreter, line 411, in do_optTag
   - Module TAL.TALInterpreter, line 406, in no_tag
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 711, in do_useMacro
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 426, in do_optTag_tal
   - Module TAL.TALInterpreter, line 411, in do_optTag
   - Module TAL.TALInterpreter, line 406, in no_tag
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 426, in do_optTag_tal
   - Module TAL.TALInterpreter, line 411, in do_optTag
   - Module TAL.TALInterpreter, line 406, in no_tag
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 653, in do_loop_tal
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 426, in do_optTag_tal
   - Module TAL.TALInterpreter, line 411, in do_optTag
   - Module TAL.TALInterpreter, line 406, in no_tag
   - Module TAL.TALInterpreter, line 250, in interpret
   - Module TAL.TALInterpreter, line 676, in do_condition
   - Module Products.PageTemplates.TALES, line 221, in evaluate
   - Module Products.PageTemplates.Expressions, line 246, in __call__
   - Module Products.PageTemplates.TALES, line 215, in evaluate
   - Module Products.PageTemplates.TALES, line 221, in evaluate
   - Module Products.PageTemplates.Expressions, line 182, in __call__
   - Module Products.PageTemplates.Expressions, line 185, in __call__
   - Module Products.PageTemplates.Expressions, line 173, in _eval
   - Module Products.PageTemplates.Expressions, line 127, in _eval
   - Module Products.PageTemplates.Expressions, line 301, in
   restrictedTraverse
   - Module Products.VerboseSecurity.VerboseSecurityPolicy, line 151, in
   validate

Unauthorized: The container has no security assertions. Access to
'getInline' of (Products.ResourceRegistries.tools.JSRegistry.JavaScriptobject
at 0xaf5fe56c) denied. (Also, an error occurred while attempting to
render the standard error message.


2006/1/17, François-Régis Chalaoux <chalaouxfr at gmail.com>:
>
> Hi,
>
> I readed your message and got same sort of problem (http://thread.gmane.org/gmane.comp.web.zope.plone.setup/361
> ) for maybe the same sort of reason.
>
> Everything is ok until Zope-2.8.4 migration where I try to
> "manage_convertIndexes" the plone_catalog, cause I got a "AttributeError:
> _length".
>
> Did you find a solution ?
>
> Bye.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-setup/attachments/20060117/6eacf486/attachment-0002.html>


More information about the Setup mailing list