[Setup] Failed migration

Sydney Weidman syd at plug.ca
Tue Jan 3 23:38:10 UTC 2006


I've been trying in fits and starts to migrate a Plone-2.0.4/Zope-2.7.4 site to
Plone-2.1.1/Zope-2.8.1 with no success yet. The old site was using a rather
clumsily customized Calendaring product. The migration terminates with the
following error:

#  Dry run selected.
# Starting the migration from version: 2.0.4
# Attempting to upgrade from: 2.0.4
# Upgrade to: 2.0.5-rc1, completed
# Attempting to upgrade from: 2.0.5-rc1
# Upgrade to: 2.0.5-rc2, completed
# Attempting to upgrade from: 2.0.5-rc2
# Renamed Folder 'properties' tab to 'edit'.
# Added 'folderlisting' action to Topics.
# Interchanged 'edit' and 'sharing' tabs.
# Upgrade to: 2.0.5, completed
# Attempting to upgrade from: 2.0.5
# Upgrade aborted
# Error type: exceptions.ValueError
# Error value: No registered migrator for '('Event', 'ATEvent')' found
# File


I had a look at the migration classes in the atctmigrator.py; can I just attempt
to write another class that will handle my customized event type?

Or is this a deeper bug?

Thanks for this great product, and thanks in advance for any help.

Regards,
Syd




More information about the Setup mailing list