[Setup] Re: attempting to upgrade plone 2.0.5 to 2.1 or 2.5

Chris Curvey chris at chriscurvey.com
Mon Aug 28 19:43:06 UTC 2006


Alexander Limi wrote:
> On Fri, 25 Aug 2006 05:22:45 -0700, news.gmane.org 
> <chris at chriscurvey.com> wrote:
> 
>> Okay, I'm getting closer.  Instead of exporting the whole site, I 
>> exported things folder-by-folder and then imported those.  That went 
>> much smoother, EXCEPT for my PloneCollectorNG instance.  That is 
>> giving me the "unpack list of wrong size".  Anybody got any 
>> suggestions?  (I'm running PCNG 1.2.7 under Plone 2.0.5.)
>>
>> I think I'm confused about which version of PCNG to install in Plone 
>> 2.1, and the sequence of installing that product vs. importing the data.
> 
> Install latest PCNG in the instance first, and try either cut/paste (not 
> copy!) from a parallel instance, or export/import.
> 

Rats.  I have just found out from the PCNG author that export/import 
will not work for this upgrade.  Which means that I have to fall back to 
using the migration tool to upgrade from 2.0.5 to 2.1 or 2.5.

So I've tried again, and gotten the same result on both 2.1 and 2.5.  I 
get an IndexError in c:\program 
files\plone21\data\products\MinetypesRegistry\mime_types\py_mimetypes.py, 
line 44, in initialize if ext[0] == '.'

Any thoughts about what this might mean?  Do I need to install a 
different version of MimetypesRegistry?  Is there a type that I need to 
install?






More information about the Setup mailing list