[Setup] Re: Can't Start Plone 2.5

Nick Davis nd51 at le.ac.uk
Tue Aug 15 08:36:06 UTC 2006


Mark Phillips wrote:
> I installed Plone2.5 on Linux using the Plone2.5-UnifiedInstaller. There
> were no errors during the build. 
> 
> When I tried to start zeo/zope/plone, I got this error:
> ImportError: No module named ImplPython
> 
> I googled around on this error, and it seemed to be a common error in early
> July with the Windows installers, but I have not found a posting with the
> solution for Linux. 
> 
> Does anyone have any suggestions?

If you were to install from source, as described here : 
http://plone.org/documentation/how-to/setup-from-source

you'd have more control of whats going on, and if something is wrong 
with your environment and/or prerequisite not met it might become more 
obvious.
Any effort / learning curve involved in would be well worth it in the 
end as this is probably something in the long run you'll find you want 
to do anyway and these are valuable skills to have.

An example of where this can help is, as Ke Liew pointed out, the error 
message you're seeing may be that your Linux install already has python 
2.3 on it (check by running python) and Plone 2.5 requires python 2.4.

I've successfully built 2.5 on a Debian Sarge box that has python 2.3 , 
by making sure Zope/Plone points to its own local 2.4 version of python 
which we built ourselves to pull in PIL etc. If you build it yourself 
from source its straighforward to make sure that happens.

HTH

Nick


-- 
Nick Davis
Web Application Developer
University of Leicester
http://www2.le.ac.uk
http://ebulletin.le.ac.uk





More information about the Setup mailing list