[Setup] Zope 2.8.7 won't start - *stumped*

Wes James comptekki at gmail.com
Thu Aug 3 19:11:40 UTC 2006

On 8/2/06, Russell Michell <R.Michell at gns.cri.nz> wrote:
> Hi folks,
> I'm having problems with starting Zope itself:
> I've installed Zope 2.8.7 on RH Linux with Python 2.3.5 behind Apache
> 2.2.2, but just can't start it. I have installed and attempted to start
> Zope as a non-root user but inside of a dir that my user does has full
> privileges. It's also a dir that is an Apache Virtual Host.
> Following the guide in docs/INSTALL.txt
> #> ./configure --prefix=/path/to/zope/<DIR>
> --with-python=/usr/local/python/bin/python
> #> make
> #> make install
> #> /path/to/zope/bin/mkzopeinstance.py
> #> username <USERNAME>
> #> password <PASSWORD>
> #> password again <PASSWORD>
> #> /path/to/zope/bin/<DIR>/bin/runzope
> It's at this last stage that the command prompt just hangs. I have left it
> for 5 minutes, tried to connect to vhost.mydomain.net:8080/manage via
> Firefox which then hangs and says 'The Connection Has Timed Out'.
> And if I start Zope using:
> #> /path/to/zope/bin/<DIR>/bin/zopectl start
> It *seems* to start. And running ps x | grep zope shows two zope
> processes, yet when I try to connect to vhost.mydomain.net:8080/manage
> again - Firefox hangs again and again then says 'The Connection Has Timed
> Out'.
> There is nothing in the apache event_log, or the Apache event_log for this
> sub-domain, nothing in Zope's Z2.log and no errors in Zope's event.log
> other than a single entry: WARNING ZODB.FileStorage Ignoring index for
> /path/to/zope/bin/<DIR>/var/Data.fs.
> I feel as though I've covered all the bases, and the only niggly feeling I
> have is that Zope needs to be installed as root but run as another user.
> Can anyone help me out here? I'm fully stuck!
> Many thanks for reading.
> Russ

Do you even see zop running?

#ps -aux|grep Zope

Do you have any other services running on port 8080?

Go in to your "zope intance"/etc and edit the zope.conf file and
change the 8080 to something else (? 8100 for instance if it is not
being used)

now run

zope-instance/bin/zopectl start

If these things are not working:

run python -V to make sure you have the python you think you are using.

check for any rogue zopes that might be running with ps -aux|grep Zope
and kill -9 any /path-to-python /instances.

rename or delete your current instance and mkzopeinstance again as the
non-root user.  You may need to create a folder like /opt/plone and
chown user /opt/plone and make your instance into that: i.e.

as root

mkdir /opt/plone
chown plone /opt/plone

as plone user


Directory: /opt/plone


start instance as user plone

/opt/plone/bin/zopectl start

you should get:

. daemon process started, pid=number

ps -aux|grep Zope

you should see 2 python processes.

browse to http://host:8080

you should get popup to log in with the username and password you provided.

Still doesn't work?

let us know.....


More information about the Setup mailing list