[Setup] Re: Plone 2.0.4 -> Plone 2.5 Errors

Nick Davis nd51 at le.ac.uk
Tue Aug 1 10:58:47 UTC 2006


Paul Sue wrote:

> OK, we tried doing everything from scratch again.
> 
> Original environment:
> 
> Zope 2.7.3/Plone 2.0.4 on server A (Redhat FC2)
> 
> We want to migrate it to server B (RedHat FC4).
> 
> 1. Installed Plone 2.5 (and Zope 2.9.3) using the Unified Installer
> 2. Copy over additional products from server A
> 3. shutdown instance on server A and server B
> 4. copy over server A's Data.fs to server B
> 5. start up instance on server B
> 6. goto ZMI on server B and run the migration tool
> 
> 
> Are we doing something wrong?
> 

Step 2 sounds dodgy.  How do you know server A's additional products are 
compatible with Plone 2.5 ? or even 2.1 and above?

If they're 3rd-party, check for later versions.

If they're your own, check for customisations that might break it, as 
described in http://plone.org/documentation/migration/2.1


You might try doing this whole process skipping step 2, or parts of step 
2. That way you can narrow down to the offending product thats causing 
it to break.


One other thing of note.
Zope 2.7.3 to Zope 2.9.3 may be a big jump , and not tried by many people.

You might try migrating to Plone 2.1.3 on Zope 2.8.7 first. This has 
been done by a lot more people , so the code has been more exercised (or 
should I say, "exorcised"  ;-)  )



-- 
Nick Davis
Web Application Developer
University of Leicester
http://www2.le.ac.uk
http://ebulletin.le.ac.uk





More information about the Setup mailing list