[Setup] Plone login behind Apache 1.3 results in Zope page?

Paul Suh paul.suh at ps-enable.com
Mon Apr 17 21:10:15 UTC 2006


Folks,

I'm trying to set up Plone behind an Apache 1.3 server. Plone is  
running on a different machine from the actual Apache server, and I  
am using VHM and proxying from httpd.conf to get the pages. Both  
servers are Mac OS X Server 10.4.6, Plone is 2.1.2 with the Tyrell  
installer. The proxy line I am using is:

                 RewriteRule ^/(.*) http://192.168.1.150:8200/ 
VirtualHostBase/http/www.ncac-cubscoutspack8.org:80/VirtualHostRoot/ 
$1 [L,P]

This works just fine for most things, but when a user logs in for the  
very first time they get the Zope default page instead of the  
expected Plone page. The URL bar contains:

http://www.ncac-cubscoutspack8.org/virtual_hosting///? 
portal_status_message=Welcome%21+You+are+now+logged+in.

Going directly to the Plone instance at 192.68.1.150:8200 and logging  
in works just fine. Behavior is the same using Safari 2, FireFox 1.5,  
and IE 6.0 (Windows). The problem seems to be the  
"virtual_hosting///" part of the URL -- delete that and the expected  
page is returned to the browser. Also, hitting the back button then  
reloading gives you the page you would expect for a logged in user.  
Logging out and logging back in from the same browser window does NOT  
give you the Zope page. Closing the browser window and opening a new  
one then logging in results in the same error.

If you want to try it for yourself, hit http://www.ncac- 
cubscoutspack8.org/ and use the user ID and password demo/bugtest.

I am new to Plone, pretty good with Apache and Mac OS X/X Server, but  
this one is a bit baffling. I tried searching gmane but nothing  
seemed to turn up.


--Paul



Paul  
Suh                                                                      
                               http://www.ps-enable.com/
paul.suh at ps- 
enable.com                                                               
        (301) 643-1516






More information about the Setup mailing list