Just reporting back to say that I found the culprit. I had separate product installed with a badly written skins.xml (badly formed xml actually).<br><br>It&#39;s concerning that a completely different product with a bad generic setup (GS) profile could cause a problem for my product, but a relief to find the problem.<br>
<br><div class="gmail_quote">On Sat, Mar 15, 2008 at 7:39 PM, Tim Knapp &lt;<a href="mailto:duffyd@kokorice.org">duffyd@kokorice.org</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="Ih2E3d">On Sat, 2008-03-15 at 19:36 -0500, David Bain wrote:<br>
&gt; Tim,<br>
&gt; Thanks for the feedback.<br>
<br>
</div>No problem.<br>
<div class="Ih2E3d"><br>
&gt; &nbsp;It seems to be a problem peculiar to a single zope instance, must<br>
&gt; have a messed up GS somewhere in another product as you suggest. I&#39;ve<br>
&gt; tried it on two other zope instances running Plone 3.0.x and it<br>
&gt; installs incident free.<br>
<br>
</div>Great to know!<br>
<div><div></div><div class="Wj3C7c">&gt;<br>
&gt; On Sat, Mar 15, 2008 at 6:46 PM, Tim Knapp &lt;<a href="mailto:duffyd@kokorice.org">duffyd@kokorice.org</a>&gt;<br>
&gt; wrote:<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Hello again David,<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; On Sat, 2008-03-15 at 10:08 -0500, David Bain wrote:<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; I have a cssregistry.xml and jsregistry.xml file in my<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; profiles/default directory. Do I need more than that?<br>
&gt;<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; The best way I find to ensure you&#39;ve got a properly configured<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; GS<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; profile is by generating it using paster create -t<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; plone3_theme as this<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; will create your zcml slug, profiles dir, setuphandler.py, and<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; the<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; marker file that will ensure the profile only gets run if you<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; have<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; specified as such in QI. But as I said sometimes *other* GS<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; profiles may<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; not include this info (esp. the marker file) and thus run when<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; yours is<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; run and cause errors.<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Generally the easiest way to determine if there&#39;s an error is<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; to have<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; your zope instance in debug mode and run via zopectl fg and<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; check the<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; console. And also to check the log created by GS setup when<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; the profile<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; is run (though this may not be present when run via the QI).<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; HTH,<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Tim<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; On Sat, Mar 15, 2008 at 3:54 AM, Tim Knapp<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &lt;<a href="mailto:duffyd@kokorice.org">duffyd@kokorice.org</a>&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; wrote:<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; Hi David,<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; Just one other thing I have noticed in the past that<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; could<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; cause this is<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; when one of the import steps in GenericSetup failed<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; (btw this<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; could also<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; be caused by another GS profile that is getting run<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; (due to a<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; badly<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; setup GS profile) automatically when yours is being<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; imported).<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; HTH,<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; Tim<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; On Fri, 2008-03-14 at 12:07 -0500, David Bain wrote:<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; And no errors are showing up in debug mode.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; On Fri, Mar 14, 2008 at 12:07 PM, David Bain<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &lt;<a href="mailto:david.bain@alteroo.com">david.bain@alteroo.com</a>&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; wrote:<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; I know it installed properly because I can<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; now add<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; the new<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; portal type to my plone site.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; On Fri, Mar 14, 2008 at 11:25 AM, Derek<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Broughton<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &lt;<a href="mailto:news@pointerstop.ca">news@pointerstop.ca</a>&gt; wrote:<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; David Bain wrote:<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &gt; What would cause a product to<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; install but<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; not be<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; listed as installed?<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Many errors in the install<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; process.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &gt; I&#39;ve created a product which,<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; when<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; installing, it<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; installs successfully<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &gt; but remains in the the<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &quot;installable&quot; list<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; for<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; quickinstaller. This happens<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &gt; when installing the product<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; under Plone<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; 3.0.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &gt; Plone 2.5.x behaves as expected.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; How do you know it installed<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; successfully?<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;I&#39;d say it<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; didn&#39;t. &nbsp;Usually<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; starting &quot;zopectl deubg&quot; will show<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; you an<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; error, even<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; though you didn&#39;t see<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; one in the install.<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; --<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; derek<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; _______________________________________________<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; Product-Developers mailing list<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <a href="mailto:Product-Developers@lists.plone.org">Product-Developers@lists.plone.org</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; <a href="http://lists.plone.org/mailman/listinfo/product-developers" target="_blank">http://lists.plone.org/mailman/listinfo/product-developers</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; _______________________________________________<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; Product-Developers mailing list<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; <a href="mailto:Product-Developers@lists.plone.org">Product-Developers@lists.plone.org</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; <a href="http://lists.plone.org/mailman/listinfo/product-developers" target="_blank">http://lists.plone.org/mailman/listinfo/product-developers</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; _______________________________________________<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; Product-Developers mailing list<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; &nbsp; &nbsp; &nbsp; &nbsp; <a href="mailto:Product-Developers@lists.plone.org">Product-Developers@lists.plone.org</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; <a href="http://lists.plone.org/mailman/listinfo/product-developers" target="_blank">http://lists.plone.org/mailman/listinfo/product-developers</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; _______________________________________________<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; Product-Developers mailing list<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; <a href="mailto:Product-Developers@lists.plone.org">Product-Developers@lists.plone.org</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; &gt; <a href="http://lists.plone.org/mailman/listinfo/product-developers" target="_blank">http://lists.plone.org/mailman/listinfo/product-developers</a><br>
&gt;<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; _______________________________________________<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Product-Developers mailing list<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; <a href="mailto:Product-Developers@lists.plone.org">Product-Developers@lists.plone.org</a><br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; <a href="http://lists.plone.org/mailman/listinfo/product-developers" target="_blank">http://lists.plone.org/mailman/listinfo/product-developers</a><br>
&gt;<br>
&gt;<br>
&gt; _______________________________________________<br>
&gt; Product-Developers mailing list<br>
&gt; <a href="mailto:Product-Developers@lists.plone.org">Product-Developers@lists.plone.org</a><br>
&gt; <a href="http://lists.plone.org/mailman/listinfo/product-developers" target="_blank">http://lists.plone.org/mailman/listinfo/product-developers</a><br>
<br>
<br>
_______________________________________________<br>
Product-Developers mailing list<br>
<a href="mailto:Product-Developers@lists.plone.org">Product-Developers@lists.plone.org</a><br>
<a href="http://lists.plone.org/mailman/listinfo/product-developers" target="_blank">http://lists.plone.org/mailman/listinfo/product-developers</a><br>
</div></div></blockquote></div><br>