[Product-Developers] plone.app.widgets nightmare

Dylan Jay djay at pretaweb.com
Mon Mar 3 09:41:14 UTC 2014


You do know plone.app.widgets is still in development and targeting plone 5
right?
I wouldn't be seriously trying to use it on plone 4.3
On 3 Mar 2014 18:25, "ajung" <lists at zopyx.com> wrote:

> Hi there,
>
> we are trying to use plone.app.widgets in a Plone 4.3 project with
> Dexterity
> since week - but the overall developer experience is more than frustration
> -
> especially for non-hardcore Plone developers of the team (I am the coach).
> We got various Javascript problems with some other 3rd party Javascript
> modules (that are supposed being compatible with the jQuery version of
> Plone
> 4.3). We basically took a step back and removed stuff that could possibly
> lead to conflict. Now we had a buildout running with some trivial Dexterity
> types and plone.app.widgets worked fine out of the box with the type. Now a
> co-worker added a RichText to his type and
> *bbbbbbbbbbbbbbbbbuuuuuuuuuuuuuuuuuuuuuummmm* : yet another JS issue.
>
> Full error see here:
>
> https://dev.plone.org/ticket/13893
>
> <rant>
> This is truly frustrating...especially for the other devs - we are
> currently
> in the we-hate-Plone mode and asking ourselves: why should we use Plone
> again?
> </rant>
>
> -aj
>
>
>
>
>
> --
> View this message in context:
> http://plone.293351.n2.nabble.com/plone-app-widgets-nightmare-tp7570364.html
> Sent from the Product Developers mailing list archive at Nabble.com.
> _______________________________________________
> Product-Developers mailing list
> Product-Developers at lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-product-developers
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20140303/0cda4236/attachment.html>


More information about the Product-Developers mailing list