[Product-Developers] ANN: plone-devstart (please help test)

Martin Aspeli optilude+lists at gmail.com
Fri Mar 16 09:59:48 UTC 2012


On 15 March 2012 21:15, Dan Jacka <danjacka at gmail.com> wrote:

>  I've tested as much as I can, but if this is to work out for a broader
>> audience, we need lots of people to test. If you have a particularly
>> messed up environment, I'd like to hear about it. :)
>>
>
> Hi Martin,
>
> For kicks I tried plone-devstart.py on a RHEL5 machine with system Python
> 2.4.3. I expected to be told that I needed 2.6.
>
> $ python plone-devstart.py devstarttest
>
>
> Welcome to plone-devstart (version 0.2)
> ...
>
> Enter a Plone version number [4.1]
>
> * Checking for known good versions set at
>   http://dist.plone.org/release/**4.1/versions.cfg<http://dist.plone.org/release/4.1/versions.cfg>...
>
> Traceback (most recent call last):
>  File "plone-devstart.py", line 449, in ?
>    main()
>  File "plone-devstart.py", line 242, in main
>    if not check_url(kgs_url):
>  File "plone-devstart.py", line 113, in check_url
>    connection = httplib.HTTPConnection(split.**netloc, port=split.port)
> AttributeError: 'tuple' object has no attribute 'netloc'
>
> Poking around, it looks like 2.4's urlparse.urlsplit returns a plain tuple
> with no 'netloc' or other attributes. [1]
>
> Could plone-devstart.py check for a supported Python version (and fail
> with a nicer error message) before checking the KGS url?
>

Yes, though we should also probably just make it run with 2.4.

Could you file an issue in the github issue tracker for plone-devstart?

Martin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20120316/f247e29c/attachment.html>


More information about the Product-Developers mailing list