[Product-Developers] DataGridField

Nicolas Azevedo nicolasazev at gmail.com
Thu Jul 19 18:26:07 UTC 2012


Thanks, this was the error.

I followed this tutorial correctly, even the creation of the database.
But when I go to fill out the form and send it gives the following errors:

Traceback (innermost last):
  Module ZPublisher.Publish, line 126, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 46, in call_object
  Module Products.CMFFormController.FSControllerPageTemplate, line 91,
in __call__
  Module Products.CMFFormController.BaseControllerPageTemplate, line
26, in _call
  Module Products.CMFFormController.FormController, line 384, in validate
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 46, in call_object
  Module Products.CMFFormController.FSControllerValidator, line 58, in __call__
  Module Products.CMFFormController.Script, line 145, in __call__
  Module Products.CMFCore.FSPythonScript, line 130, in __call__
  Module Shared.DC.Scripts.Bindings, line 322, in __call__
  Module Shared.DC.Scripts.Bindings, line 359, in _bindAndExec
  Module Products.PythonScripts.PythonScript, line 344, in _exec
  Module script, line 20, in fgvalidate_base
   - <FSControllerValidator at /Plone/fgvalidate_base used for
/Plone/advanced-form>
   - Line 20
  Module Products.PloneFormGen.content.form, line 574, in fgvalidate
  Module Products.PloneFormGen.content.form, line 589, in
fgProcessActionAdapters
  Module Products.Archetypes.ClassGen, line 56, in generatedAccessor
  Module Products.TALESField._field, line 59, in get
  Module Products.CMFCore.Expression, line 50, in __call__
  Module zope.tales.expressions, line 217, in __call__
  Module Products.PageTemplates.Expressions, line 155, in _eval
  Module Products.PageTemplates.Expressions, line 105, in render
  Module Products.PageTemplates.ZRPythonExpr, line 80, in call_with_ns
  Module Shared.DC.Scripts.Bindings, line 336, in __render_with_namespace__
  Module Shared.DC.Scripts.Bindings, line 359, in _bindAndExec
  Module Products.PythonScripts.PythonScript, line 344, in _exec
  Module script, line 3, in py_form_process
   - <PythonScript at /Plone/advanced-form/py_form_process>
   - Line 3
AttributeError: Request


Someone tell me what is it? Thanks.


Att,

# Nicolas Azevedo Costa.
# 5º período de Bacharelado em Sistemas de Informação.
# Instituto Federal Catarinense - Câmpus Araquari, SC.



2012/7/17 Jean Jordaan <jean.jordaan at gmail.com>

> On Wed, Jul 18, 2012 at 3:00 AM, Nicolas Azevedo <nicolasazev at gmail.com>
> wrote:
> > I'm following this
> > tutorial(
> http://plone.org/products/ploneformgen/documentation/tutorial/advanced-sql-crud-with-ploneformgen/tutorial-all-pages
> )
> > to learn how to use this product, but when I create the python script
> > "py_insert_data" happens a syntax error "invalid syntax (Script (Python),
> > line 17)."
>
> I just looked at the page for a second, and I noticed there's a
> missing colon at the end of this line:
>
>     for key in data['keywords']
>
> It should be:
>
>     for key in data['keywords']:
>
> Read the scripts carefully, and try them out step by step to make sure
> you follow what they're doing.
>
> --
> jean                                              . .. .... //\\\oo///\\
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20120719/0dfc276f/attachment.html>


More information about the Product-Developers mailing list