[Product-Developers] selenium testing with robotframework

Héctor Velarde hector.velarde at gmail.com
Mon Jan 16 18:30:07 UTC 2012


I solved this reinstalling Selenium IDE Firefox add-on; tests are now 
running.

I'm going to update some of the packages to see what happens; right now 
I have:

[buildout]
extends = buildout.cfg
extensions = mr.developer
parts += plonesite robot selenium library-settings
find-links = http://packages.affinitic.be/simple
versions = versions
allow-hosts += *.affinitic.be

auto-checkout += robotframework-seleniumlibrary

[versions]
robotframework = 2.6.2-st
collective.recipe.plonesite = 1.5

[sources]
robotframework-seleniumlibrary = hg 
https://gotcha-mouse-at-commands.googlecode.com/hg/gotcha-mouse-at-commands

[plonesite]
recipe = collective.recipe.plonesite
profiles = collective.newsflash:default

[robot]
recipe = zc.recipe.egg
eggs = robotframework
        robotframework-seleniumlibrary

[selenium]
recipe = hexagonit.recipe.download
download-only = true
url = 
http://selenium.googlecode.com/files/selenium-server-standalone-2.16.1.jar
filename = selenium-server.jar

[library-settings]
recipe = collective.recipe.template
input = templates/library-settings.txt.in
output = ${buildout:directory}/acceptance-tests/library-settings.txt

I want to remove dependencies on branches first; if anybody else is 
interested on working on this, let me know.

best regards

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4926 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20120116/6ac01b7c/attachment.p7s>


More information about the Product-Developers mailing list