[Product-Developers] selenium testing with robotframework

Héctor Velarde hector.velarde at gmail.com
Fri Jan 13 18:01:42 UTC 2012


I got Selenium running using:

java -jar parts/selenium/selenium-server.jar

but I have the same issue: tests seem to start, Firefox opens, but 
nothing happens.

I'm running Ubuntu 11.10 and my default browser is Aurora (Firefox 
11.0a2); do you think this could be an issue? how can I set the default 
browser?

this is what I get on one screen:

# java -jar parts/selenium/selenium-server.jar
ene 13, 2012 11:59:40 AM org.openqa.grid.selenium.GridLauncher main
Información: Launching a standalone server
11:59:40.745 INFO - Java: Oracle Corporation 21.0-b17
11:59:40.754 INFO - OS: Linux 3.0.0-14-generic amd64
11:59:40.770 INFO - v2.11.0, with Core v2.11.0. Built from revision 14431
11:59:41.147 INFO - RemoteWebDriver instances should connect to: 
http://127.0.0.1:4444/wd/hub
11:59:41.150 INFO - Version Jetty/5.1.x
11:59:41.151 INFO - Started 
HttpContext[/selenium-server/driver,/selenium-server/driver]
11:59:41.153 INFO - Started HttpContext[/selenium-server,/selenium-server]
11:59:41.153 INFO - Started HttpContext[/,/]
11:59:41.250 INFO - Started 
org.openqa.jetty.jetty.servlet.ServletHandler at b68e546
11:59:41.250 INFO - Started HttpContext[/wd,/wd]
11:59:41.273 INFO - Started SocketListener on 0.0.0.0:4444
11:59:41.273 INFO - Started org.openqa.jetty.jetty.Server at 30407e62
11:59:53.339 INFO - Checking Resource aliases
11:59:53.373 INFO - Command request: getNewBrowserSession[*firefox, 
http://localhost:8080, ] on session null
11:59:53.390 INFO - creating new remote session
11:59:53.541 INFO - Allocated session 8c9a493cda2e458a97b89de53f05b089 
for http://localhost:8080, launching...
11:59:53.847 INFO - Preparing Firefox profile...
11:59:57.856 INFO - Launching Firefox...

and this is what I get on the other:

# bin/pybot acceptance-tests
==============================================================================
Acceptance-Tests 

==============================================================================

best regards

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4926 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20120113/d81fb212/attachment.p7s>


More information about the Product-Developers mailing list