[Product-Developers] [Jenkins] Integration of Tests/JUnit integration

Andreas Jung lists at zopyx.com
Wed Jul 27 05:22:40 UTC 2011


Hi there,

I am currently in progress setting up a Jenkins server for Plone projects.

I followed

http://www.martinaspeli.net/articles/using-hudson-ci-for-plone-projects

so far and used jarn.recipe.jenkins...everything is fine so far.

I am using the following  free-style build script to build my sandbox and
run
the tests...

rm -fr  /home/pacs/ves00/integration-testing/sandboxes/ise-trunk
mkdir /home/pacs/ves00/integration-testing/sandboxes/ise-trunk
cd /home/pacs/ves00/integration-testing/sandboxes/ise-trunk
svn checkout
https://ext1.svn.banality.de/projects/frauenhofer/buildouts/trunk .
python2.6 bootstrap.py -c dev.cfg
bin/buildout -c dev.cfg
bin/test-jenkins --xml -x -s ise.policy -s vs.org

The tests are executed properly by Jenkins

+ bin/test-jenkins --xml -x -s ise.policy -s vs.org
.............

..............

Total: 27 tests, 0 failures, 0 errors in 33.243 seconds.
Finished: SUCCESS


however Jenskins refuses to accept  a path like


/home/pacs/ves00/integration-testing/sandboxes/ise-trunk/parts/test-jenkins/testreports/*.xml


for the "publish JUnit test results" option but the path above exists
and  the *xml files exists.


There is always an error message


'/home/pacs/ves00/integration-testing/sandboxes/ise-trunk/parts/test-jenkins/testreports/*.xml'
liefert keine Übereinstimmung: '' existiert, nicht aber
'/home/pacs/ves00/integration-testing/sandboxes/ise-trunk/parts/test-jenkins/testreports/*.xml'.
*(EN: "....xml no match" exists, but not "....*xml").*
*
*
*
*
*I found references to the "workspace" configuration (which is empty in my
case)*
*
*
*Any idea?*
*
*
*Andreas
*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20110727/06509d58/attachment.html>


More information about the Product-Developers mailing list