[Product-Developers] Releasing plugins to pypi AND plone.org

Gilles Lenfant gilles.lenfant at alterway.fr
Wed Apr 6 11:09:48 UTC 2011


Hi,

Your ~/.pypirc seems correct. It looks like you are using Python 2.4 to run setup.py.

AFAIK this requires Python 2.6, or Python 2.4/2.5 plus "collective.dist", and use "mregister" in place of "register" and "mupload" in place of "upload".

HTH
-- 
Gilles Lenfant

Le 6 avr. 2011 à 12:17, Espen Moe-Nilssen a écrit :

> I tried to setup this, what is wrong here: 
> 
> [distutils] 
> index-servers = 
>    pypi 
>    plone 
> 
> [pypi] 
> username:espen 
> password:xxxxxxxx 
> 
> [plone] 
> respository: http://plone.org/products
> username: espenmn 
> password: xxxxxxxxx 
> 
> 
> ----------------------- 
> 
> 
> setup.py  register sdist upload -r plone 
> 
> tries to upload to py 
> 
> 
> Espen 
> 
> 
> View this message in context: Re: Releasing plugins to pypi AND plone.org
> Sent from the Product Developers mailing list archive at Nabble.com.
> _______________________________________________
> Product-Developers mailing list
> Product-Developers at lists.plone.org
> https://lists.plone.org/mailman/listinfo/product-developers




More information about the Product-Developers mailing list