[Product-Developers] Re: Package versions, Plone 3, Plone 4
novotny.radim at gmail.com
Thu Mar 18 16:58:54 UTC 2010
> What I did for Poi is this:
> - Trunk (2.0, first alpha release is out) is targeting Plone 4 only. It
> has 'Plone>=4.0a1' in its install_requires. This avoids getting Poi 2
> in a Plone 3 site, which would only cause pain.
I've tried to add Poi to Plone 3.3.5 instance and run buildout:
Getting distribution for 'Products.Poi'.
Got Products.Poi 2.0a1.
Getting distribution for 'collective.watcherlist>=0.2'.
Got collective.watcherlist 0.2.
Error: There is a version conflict.
We already have: Plone 3.3.5
but Products.Poi 2.0a1 requires 'Plone>=4.0a1'.
That is not so bad, but user may be confused. What should BFU do in this
situation? Go to product page and read comaptibility matrix? Moreover,
PyPI does not list older releases :( so it is not so easy to find
available versions (except changelog)
More information about the Product-Developers