[Product-Developers] [i18n] The i18n game

Andreas Jung lists at zopyx.com
Thu Mar 18 12:37:53 UTC 2010


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi there,

we have a fairly large Plone 3.1 site (site language is DE) which
several add-ons and policy packages. Now we created a new package
idg.translations in order to override some Plone translations with
our own translations (in DE).

After the installation of the package (mr.developer, eggs + zcml slug)
the *complete* Plone site is show in English *only*.

I tried to track this down...removing the ZCML slug for idg.translations
brings the site back with German UI - re-adding the slut -> EN again.

Ok - I tried to track this down:

 - I removed the only .po file:

/src/idg.translations/idg/translations/locales/de/LC_MESSAGES/plone.po,
restarted the instance with ZCML slug -> site UI is in EN

 - I removed the registerTranslations configuration from the configure.zcml:

<configure
    xmlns="http://namespaces.zope.org/zope"
    xmlns:i18n="http://namespaces.zope.org/i18n"
    i18n_domain="plone">
  <i18n:registerTranslations directory="locales" />
</configure>

 and restarted -> site UI is in EN

The package does not contain any other stuff - only the configure.zcml
and the 'locales' subfolder.

What the hell is going on here?

- -aj


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkuiHqEACgkQCJIWIbr9KYyJQQCaAikZvIYMzXFp1xVG/4z7lNMk
YdQAoM+50rtYquf6RETAiiq+jWrMlQW8
=eH4d
-----END PGP SIGNATURE-----
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lists.vcf
Type: text/x-vcard
Size: 316 bytes
Desc: not available
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20100318/5a456286/attachment.vcf>


More information about the Product-Developers mailing list