[Product-Developers] Re: collective.monkeypatcher -- awkward names

Jean Jordaan jean.jordaan at gmail.com
Fri Feb 12 04:10:38 UTC 2010


Hello :-)

> I think the "replace" and "inject" use cases are different. I don't
> mind if "inject" by default uses the patch method name as the new
> method name, so long as you get an error if the item is already there
> (in all "new" cases). I do mind if "replace" assumes they are the
> same.

I'm OK with these semantics also, but struggle to reconcile it with your
statement: "I rarely use the same name in my patches, preferring
something a bit more explicit so people don't accidentally think they're
meant to call it." Why would people only accidentally call replacement
methods and not new methods? Anyway, this is only a quibble with your
motivation; I'm OK with the conclusions.

>> I would be fine with (2) (3) (4) as an improvement on the current way
>> of adding a new member. I don't like changing from 'patch' to 'new'
>> in (5) and I don't think (6) is terribly useful.
>
> Agree.

Cool. If I get some time I'll make a patch.

> The point about ctags is a good one (I don't use ctags myself),

Try it, it's great. I use vim with ctags, but I'm sure IDEs do the same
kind of thing.

-- 
jean                                              . .. .... //\\\oo///\\




More information about the Product-Developers mailing list