[Product-Developers] Products.TinyMCE french translation

JeanMichel FRANCOIS jeanmichel.francois at makina-corpus.com
Mon Sep 7 13:34:45 UTC 2009


Hi Rob,

I have an other issue with the translation: ploneimage.image_desc in the 
alt of the image button (toolbar). In english it's supposed to display 
"Insert/edit image". In the translation french translation it is 
supposed to display "Insérer/Éditer image". But it display 
"ploneimage.image_desc"

First I have tryed by fixing the typo between "ploneimage.image_desc" 
(from js) and "ploneimage_image_desc" (from po) but it still fails.

Any idea ?

Rob Gietema a écrit :
> Hi Jean-Michel,
>
> Thank you for adding the translations.
>
> You are correct with the first issue, I'll fix that.
>
> TinyMCE uses 2 i18n domains. The "tinymce" .po files are generated 
> automatically based on the translations which are allready available 
> for TinyMCE. The "plone.tinymce" domain contains the plone specific 
> translations of TinyMCE and are the ones which should be translated.
>
> The .mo files are indeed compiled. Some product authors include them 
> in svn others don't, I don't know what best practice is here.
>
> Cheers,
>
> Rob Gietema
> Four Digits
>
>
> On Fri, Sep 4, 2009 at 10:36 PM, Jean-Michel FRANCOIS 
> <jeanmichel.francois at makina-corpus.com 
> <mailto:jeanmichel.francois at makina-corpus.com>> wrote:
>
>     Hi,
>
>     I have added french translation to Products.TinyMCE trunk. It was
>     kinda
>     boring but it's done. If some french around want to check my work I
>     would be glade to be reviewed.
>
>     I have some strange issues and remarks to do:
>
>     1)
>     >From interfaces/utility.py line 407:
>            vocabulary=SimpleVocabulary([SimpleTerm('named', 'Named'),
>     SimpleTerm('numeric', 'Numeric'), SimpleTerm('raw', 'Raw')]),
>     Means that terms can not be translated, isn't it ?
>     ---
>     2)
>     Every language under locales use tinymce.po as "tinymce" is the
>     domain.
>     But the template is only for "plone.tinymce" domain. I don't
>     understand.
>     Do the first has to be deleted ?
>     ---
>     3)
>     My last question is more a newb question about the i18n machinery. Why
>     is the *.mo files are versionned ? As far as I know, Plone build
>     the mo
>     files when zope is starting up.
>
>
>     --
>     Cordialement,
>     Jean-Michel FRANCOIS
>     Makina-Corpus
>
>
>
>     _______________________________________________
>     Product-Developers mailing list
>     Product-Developers at lists.plone.org
>     <mailto:Product-Developers at lists.plone.org>
>     http://lists.plone.org/mailman/listinfo/product-developers
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Product-Developers mailing list
> Product-Developers at lists.plone.org
> http://lists.plone.org/mailman/listinfo/product-developers
>   





More information about the Product-Developers mailing list