[Product-Developers] Re: Need Help with External Method

Maurits van Rees m.van.rees at zestsoftware.nl
Tue Sep 1 21:14:49 UTC 2009


Mark Phillips, on 2009-09-01:
>
> I have Plone-2.5.5 installed with as a zeocluster. I created two sites, one
> ahs and one ahs_dev. Each one has a separate data.fs file in separate
> directories. Each site has identical products. I added a python script to
> the Extensions directory under client1, client2, and skel. I am able to add
> the script as an external method in the ahs site and it works. When I try to
> add the same script as an external method in the ahs_dev site, I get a 404
> Error - object not found. Why can't I add the external method to the second
> site? I even tried renaming the script and I still cannot add an external
> method to the second site. What am I doing wrong? Everything else works in
> the ahs_dev site.

Go to the error_log of ahs_dev, remove or #comment out the line with
NotFound.  Then try adding that external method again and see if that
now gives you a proper traceback; hopefully that contains more hints.
When you get a 404 on a page it is not always that page itself that
cannot be found.

Having said that, I *can* imagine that the separate Data.fs files are
the cause for the problem here; if that is the case then I would call
this a bug.

-- 
Maurits van Rees | http://maurits.vanrees.org/
            Work | http://zestsoftware.nl/
"This is your day, don't let them take it away." [Barlow Girl]





More information about the Product-Developers mailing list