[Product-Developers] Re: Simple extension policy product doesn't show in Products

Maurits van Rees m.van.rees at zestsoftware.nl
Tue Jun 23 21:07:39 UTC 2009

rcecil, on 2009-06-23:
> Hello,
> I'm trying to follow Aspeli, pp 69-71, where he describes the initial
> creation of a policy product  using
> paster create -t plone optilux.policy

I run into problems when I execute this literally and then actually
call the package me.test: there are several spots in the generated
that point to optilux.policy.  I would just do:

  paster create -t plone

> I have tried the same using a fresh plone site (created via paster create -t
> plone3_buildout...). I named my policy product "me.test" (created in the src
> folder obviously).
> I edited my buildout.cfg to add "me.test" under "eggs", "src/me.test" under
> "develop" and "me.test" under [instance] zcml, and then rerun buildout.
> See: http://paste.plone.org/28645
> I can go into bin/zopepy, and run
> "from me import test" 
> and I get no errors.
> When I restart plone/zope, the product doesn't show in Control_Panel under
> Add-On Products though.

Do you mean the Zope Control Panel or the Plone control panel (site
setup)?  I assume the Zope one, so the Products url would be

Is that the one you mean?

If yes, then it works fine for me when I try it.

Do you get any errors when starting the instance on the foreground,
so with 'bin/instance fg'?  The normal 'bin/instance start' can
continue when faced with errors that on the foreground would quit the
process.  The jury is still out on whether that is a feature or a
bug... ;-)

> Any ideas?
> Contents of src/me.test: http://paste.plone.org/28646
> Contents of src/me.test/me/test/configure.zcml: http://paste.plone.org/28647

Both seem fine.

Maurits van Rees | http://maurits.vanrees.org/
            Work | http://zestsoftware.nl/
"This is your day, don't let them take it away." [Barlow Girl]

More information about the Product-Developers mailing list