[Product-Developers] Re: GS/QS installing issues on Plone 3.1

Andreas Jung lists at zopyx.com
Mon May 12 14:29:06 UTC 2008



--On 12. Mai 2008 16:10:17 +0200 Daniel Nouri <daniel.nouri at gmail.com> 
wrote:

> Andreas Jung writes:
>
>> For a new project/product (for Plone 3.1) I am setting up a complete
>> installation infrastructure.
>>
>> - defining an extension profile for the project creates a new item within
>>   the add/remove programs control panel - fine
>>
>> Questions:
>>
>> - how do you define additional 3rd-party products that should be
>> installed additionally (should replace installProduct() calls as one did
>>   in former times within Extenstions/Install.py)?
>>
>> - while having an extension profile and a local Extension/Install.py
>> file, the Install.install() does not seem to be executed using this
>>   approach? Or am I missing something? In my case I need additional
>>   actions being taken (e.g. for setting up some vocabularies with
>>   ATVocabularyManager).
>
> For these, you'll need to setup a setup handler.
>
> See
> -
> http://dev.plone.org/plone/browser/CMFPlone/branches/3.1/profiles/default
> /import_steps.xml#L123 -
> http://dev.plone.org/plone/browser/CMFPlone/branches/3.1/setuphandlers.py
> #L489
>
>

Sorry but that does not answer my question. Why should I have to write
my own setup handler for installing other 3rd-party products through GS?
This is a common task and should be part of the Plone framework (wasn't 
that one of the additions being made for Plone 3.1?).

I am confused.

Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20080512/55ca2e43/attachment.asc>


More information about the Product-Developers mailing list