[Product-Developers] Re: Catalog search problems

Derek Broughton news at pointerstop.ca
Thu Mar 6 23:58:46 UTC 2008


Maurits van Rees wrote:

> Swank, Craig, on 2008-03-06:
>> Thanks for the reply, Andreas.  Yes, I have tried reindexing, clearing
>> and
>> rebuilding, you name it.  It is almost as if the catalog search is being
>> done on another catalog, but I don't have another catalog.
> 
> You say you query the catalog like this:
> 
> brains = portal_catalog(portal_type="Folder")
> 
> Where do you do that?  Is that in a zopectl debug session?  Because I
> have seen different results while querying the catalog in a zopectl
> debug session ('bin/instance debug' in a normal buildout) than when in
> file system code or a pdb session.

I wondered, too, because the very first time I tried this I got the same
results, until I realized that what I was looking for just wasn't available
to an anonymous user.  In zopectl, you have to create your login
credentials first.  This is the sort of thing where debugging via clouseau
really shines.
-- 
derek





More information about the Product-Developers mailing list