[Product-Developers] Catalog search problems

Andreas Jung lists at zopyx.com
Thu Mar 6 17:03:14 UTC 2008



--On 6. März 2008 08:49:48 -0800 swank <craig_swank at nrel.gov> wrote:

>
> Hello,
> I am having trouble with catalog searches.  When I do a search for a
> portal_type such as:
>
> brains = portal_catalog(portal_type="FtirRecord")
>
> I get no results (brains = []).  My portal catalog seems to be fine when I
> look at it from the management interface.  FtirRecord is a type listed in
> the portal_type index.  I tried doing
>
> brains = portal_catalog(portal_type="Folder")
>
> and I still get no results.  When I do:
>
>

Try to reindex the whole catalog and try again. Otherwise I would not
believe this.

-aj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20080306/ffab41c1/attachment.asc>


More information about the Product-Developers mailing list