[Product-Developers] Catalog search problems

swank craig_swank at nrel.gov
Thu Mar 6 16:49:48 UTC 2008

I am having trouble with catalog searches.  When I do a search for a
portal_type such as:

brains = portal_catalog(portal_type="FtirRecord")

I get no results (brains = []).  My portal catalog seems to be fine when I
look at it from the management interface.  FtirRecord is a type listed in
the portal_type index.  I tried doing 

brains = portal_catalog(portal_type="Folder")

and I still get no results.  When I do:

brains = portal_catalog()

just to see what happens, I get results, but every single returned item in
the list is of type Products.Archetypes.Schema.Schema (that is, for each
item in the list, item.portal_type = Products.Archetypes.Schema.Schema). 
None of the other types that are listed in my portal_types index are
returned in the search.

Another piece of information, the code that I'm using works in another
buildout (3.0.5) that I have on my computer.  I can't figure out why one
works and the other doesn't.  I'm stumped!


Craig Swank
View this message in context: http://www.nabble.com/Catalog-search-problems-tp15878022s20094p15878022.html
Sent from the Product Developers mailing list archive at Nabble.com.

More information about the Product-Developers mailing list