PressRoom Issue

Jon Baldivieso jonb at onenw.org
Mon Oct 29 19:33:15 UTC 2007


Thanks for finding this bug, Eric.  I've fixed it in the PressRoom  
trunk and will be rolling out a 3.1 release at some point this week  
that contains that as well as a few other improvements.  (My bad  
advice below shows I wasn't aware of how Generic Setup had evolved in  
between 2.5 and 3 -- there is no longer a concept of a Generic Setup  
"active profile" other than the base profile, hence this bug.)
___________________________
Jon Baldivieso
503.222.5064
ONE/Northwest Portland Office

New tools and strategies for engaging people in protecting the  
environment



On Oct 27, 2007, at 8:33 PM, Jon Stahl wrote:

>
> Eric-
>
> JonB's the lead developer; you should trust him more than me. ;-)
>
> In addition, you might want to try using PressRoom 3.0-final, which  
> has a
> few fixes over PressRoom 3.0-RC
>
> That said, I am able to reproduce the problem with PressRoom 3-0- 
> final.
>
> Consider the bug confirmed; I'm going to file it now.   And again,  
> thanks
> for drawing our attention to this!
>
> best,
> jon
>
>
> Jon Baldivieso wrote:
>>
>> Eric -- I've seen this happen once before, but blamed it on the
>> circumstances of the site itself.  Now I think my install method is
>> not playing properly with Plone's Generic Setup profile.  Until I fix
>> this, you *might* have success by designating a different active
>> site  configuration (I suspect any other than Plone will do) in the
>> properties section of portal_setup and then trying to install  
>> PressRoom.
>>
>> Jon Baldivieso
>>
>> On Oct 26, 2007, at 8:00 PM, Eric S. Tyrer II wrote:
>>
>>> In article <47228B3A.8060509 at onenw.org>,
>>>  Jon Stahl <jon at onenw.org> wrote:
>>>
>>>>>
>>>> Eric-
>>>>
>>>> As its release state (perhaps less clearly than they should!),
>>>> PressRoom
>>>> 1.1.1 is not compatible with Plone 3.0.
>>>>
>>>> Please upgrade to PressRoom 3.0, which is (as its version number
>>>> hopefully implies) Plone 3.0 compatible.
>>>>
>>>> If you find any bugs, please report them to our issue tracker at
>>>> http://plone.org/products/pressroom/issues
>>>>
>>>> Thanks!
>>>>
>>>> -jon
>>>
>>> Jon..
>>>
>>> Thanks for the prompt reply.. but I am a bit confused on your
>>> resolution. This is what we currently
>>>
>>> Our data.fs is a migrated 2.5.2 to 3.0.2
>>>
>>> Prior to migration we tested a 2.5.2 compatible version of  
>>> PressRoom.
>>>
>>> ---
>>> that brings us to the present:
>>>
>>> We have Plone 3.0.2 running (1 zeo + 2 clients) PressRoom 3.0 RC is
>>> installed in our products folder with the same permissions and  
>>> user as
>>> Plone.
>>>
>>> Using the quick-installer, or preferences/add-remove products
>>> PressRoom
>>> does not move from uninstalled column to the installed column
>>>
>>> checking the error log gives me the error that i posted
>>> perviously:KeyError CMF:plone
>>>
>>> Could this have been from our migration? a key error is a python
>>> call to
>>> a nonexistent object.. would it be in the catalog?
>>>
>>> i am bummed becuase this product would really help is out.
>>>
>>> I will submit it as a bug if you think it is..
>>>
>>> Thanks Again
>>>
>>> Eric
>>>
>>>
>>> _______________________________________________
>>> Product-Developers mailing list
>>> Product-Developers at lists.plone.org
>>> http://lists.plone.org/mailman/listinfo/product-developers
>>
>>
>> _______________________________________________
>> Product-Developers mailing list
>> Product-Developers at lists.plone.org
>> http://lists.plone.org/mailman/listinfo/product-developers
>>
>>
>
> -- 
> View this message in context: http://www.nabble.com/PressRoom-Issue- 
> tf4695044s20094.html#a13449787
> Sent from the Product Developers mailing list archive at Nabble.com.
>
>
> _______________________________________________
> Product-Developers mailing list
> Product-Developers at lists.plone.org
> http://lists.plone.org/mailman/listinfo/product-developers

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.plone.org/pipermail/plone-product-developers/attachments/20071029/67b52773/attachment.html>


More information about the Product-Developers mailing list