<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-15">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Salve a tutti,<br>
    ho riscontrato un problema con Lineage; il problema Ŕ semplice ma
    non riesco a capire come risolvere: dovrei rinominare un sotto sito
    Lineage e spostarlo da un sito Plone ad un altro ma, dopo avere
    spostato la cartella e il suo contenuto nel nuovo sito, quando vado
    ad interrogare la stessa cartella/sotto sito Lineage ricevo sempre
    lo stesso errore di
    <meta http-equiv="content-type" content="text/html;
      charset=ISO-8859-15">
    <b>KeyError('id_vecchio_sito',)</b><br>
    <br>
    Sembra che una volta che alla cartella venga assegnato il subtype
    "Child site" Lineage registri la nuova <i>root path</i> in maniera
    permanente senza possibilitÓ di poter rinominare l'oggetto in
    seguito<br>
    <br>
    Ho provato ad eliminare e poi a riassegnare all'oggetto
    l'interfaccia
    <meta http-equiv="content-type" content="text/html;
      charset=ISO-8859-15">
    <i>collective.lineage.interfaces.IChildSite</i> ma senza successo.
    Gli ID registrati da Lineage, sia del sito Plone che della cartella,
    rimangono sempre gli stessi<br>
    <br>
    Ho provato a cercare di risolvere attraverso le configurazioni di <i>portal_registry</i>
    ma non ho trovato nulla di utile<br>
    <br>
    Avete qualche suggerimento in merito?<br>
    <br>
    Un'ulteriore domanda in merito a Lineage: esiste un metodo per
    riportare la cartella da <i>Child Site </i>a <i>Folder </i>di
    Plone oltre a quello di cancellare l'interfaccia dall'oggetto come
    descrivo sopra?<br>
    <br>
    <br>
    Grazie a tutti in anticipo dell'aiuto che potrete darmi<br>
    Un saluto<br>
    Roberto Rascioni<br>
    <br>
  </body>
</html>