[Plone-IT] Plone 5 - Dexterity e visualizzazione

emily emilyxmanfredi a gmail.com
Ven 20 Apr 2018 12:49:46 UTC


Salve a tutti,

ho un'instanza di Plone 5, dove mi sono creata il mio content-type con
dexterity, fatto direttamente non da portale ma da codice.
Quando vado a crearmi il mio nuovo "oggetto", mi crea tutto senza problemi.

Nella visualizzazione per˛ mi mostra in automatico anche il title e la
description dei campi che ho creato.
Gli unici due campi che non vengono mostrati nella visualizzazione sono
Title e Description, dove mi mostra l'effettivo contenuto.


Per intenderci ho creato una cosa del genere:

title = schema.TextLine(
        title=_(u'Titolo'),
        required=True,
    )

description = schema.Text(
        title=_(u'Descrizione'),
        description=_(u'Descrizione'),
        required=False,
    )


extract = RichText(
        title=_(u'Riassunto'),
        description=_(u"ComparirÓ in home page, a lato e nell'archivio."),
        default_mime_type='text/x-rst',
        output_mime_type='text/x-html',
        required=True,
    )

image = NamedBlobImage(
        title=_(u"Immagine"),
        description=_(u"ComparirÓ insieme al riassunto del Focus."),
        required=True,
    )


Dove per title e description, mi mostra solo in contenuto e per extract ed
image, mi mostra si il contenuto ma anche le varie label di title e
description.

Ho provato a creare un content-type direttamente da interfaccia, ma mi da il
solito "problema".
Molto probabilmente c'Ŕ una qualche configurazione che non riesco a trovare
o non so...

Qualcuno sa darmi una dritta?

Chiedo venia di nuovo per la mia nubiaggine.



--
Sent from: http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html


Maggiori informazioni sulla lista Plone-IT