[Plone-IT] Migrare un plone 4 a plone 5

Mirotti Fabio mirof a comune.modena.it
Ven 3 Feb 2017 14:06:02 UTC


Grazie a tutti per l’aiuto, 
direi proprio che il suggerimento di Yuri ha risolto il mio problema, 
importando anche il reference_catalog ho mantenuto tutti i correlati e ora ho anche un registry pulito
e facetednavigation funziona a dovere. 
Rimane il fatto che la procedura di upgrade forse ha ancora qualche cosuccia da mettere a punto.

Ciao 

	—Fabio 


> Il giorno 02 feb 2017, alle ore 10:17, Yuri <yurj a alfa.it> ha scritto:
> 
> Dopo ai contenuti, importa il catalogo e poi reindicizza tutto, in teoria dovrebbe mantenere i collegamenti corretti.
> 
> Detto questo, sarebbe utile capire perché l'upgrade non viene fatto correttamente. Molte volte capita che alcuni upgrade step del profilo non vengono lanciati, e si rimedia lanciandoli a mano.
> 
> 
> 
> Il 02/02/2017 09:42, Fabio Mirotti ha scritto:
>> 
>> Ciao,
>> 
>> Sto facendo alcune prove di migrazione da plone 4 a plone 5 su un piccolo sito che contiene solo tipi standard:
>> pagine e news, l'unica particolarita' e' che diverse pagine contengono elementi correlati.
>> 
>> Non sono installati prodotti particolari, l'unico utilizzato e'  eea.facetednavigation.
>> 
>> Anche lo skin e' sunburst di base l'unica personalizzazione e' il cambio del logo applicato alla custom.
>> 
>> Questo scenario dovrebbe essere il piu' tra i piu' semplici per effettuare una migrazione ma sto trovando qualche problema.
>> 
>> In particolare quello che ho fatto e' stato:
>> 
>> - aggiornare il sito vecchio alla 4.3.11 -- OK
>> - aggiornare eea.facetednavigation alla 10.0 -- OK
>> - prepararmi un buildout fresco plone 5.0.6 -- OK
>> - con la stessa versione di facetednavigation -- OK
>> - copiare Data.fs e blobstorage -- OK
>> - avviare plone 5 -- OK
>> - lanciare upgrade di configurazione -- OK
>> - migrare i contenuti da AT a dexterity -- OK
>> 
>> e fino qui tutto OK, i contenuti sono a posto, anche gli elementi correlati sono stati migrati correttamente.
>> 
>> Pero' a livello di interfaccia mi trovo alcune cose che non mi tornano...
>> 
>> Ad esempio:
>> - la gestione delle portlet e' rimasta quella di plone 4, non posso gestire le portlet del footer.
>> - il footer e' rimasto quello vecchio...
>> - faceted non funziona perche' non carica jQuery.bbq che a quanto pare non viene aggiunto al bundle dei javascript...
>> 
>> Naturalmente se faccio un sito nuovo sulla stessa istanza funziona tutto correttamente, avevo anche provato ad esportare e
>> reimportare i contenuti, pero' in questo modo mi vanno in errore i relatedItems che sono presenti in diverse pagine del sito :(
>> 
>> La domanda.... c'e' un qualche modo vi a ZMI di eliminare del tutto il registro di configurazione che si e' portato dietro in fase di migrazione
>> e fargli prendere quello del plone 5 di default? Altri consigli utili per la migrazione?
>> 
>> Grazie per l'aiuto.
>> 
>>    ---Fabio
>> 
>> 
>> _______________________________________________
>> Plone-IT mailing list
>> Plone-IT a lists.plone.org
>> https://lists.plone.org/mailman/listinfo/plone-plone-it
>> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
> 
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-plone-it
> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



Maggiori informazioni sulla lista Plone-IT