[Plone-IT] Migrare un plone 4 a plone 5

Luca Fabbri luca.fabbri a abstract.it
Gio 2 Feb 2017 12:22:49 UTC


Ciao Fabio!

A mio parere molti dei problemi di layout che hai sono dovuti al tema
grafico...  possibile che in qualche modo sia rimasto selezionato il
tuo vecchio tema, basato su sunburst, ma tieni presente che Plone 5
usa Barceloneta.

Se come dici non hai grosse personalizzazioni a livello di tema ti
consiglio di provare a attivare quest'ultimo e ripartire con le
personalizzazioni.

Altra cosa: controlla di non avere personalizzazioni nel portal_skins/custom.

Il problema di eea.facetednavigation  pi subdolo, ma magari  legato
di nuovo al tema e al fatto che forse non stai usando il nuovo
registro delle risorse (anche se mi pare strano).

Stai usando la versione 10 e hai eseguito i passi di migrazione?
https://pypi.python.org/pypi/eea.facetednavigation/10.0#upgrade-to-version-10-0

Buona fortuna!


2017-02-02 9:42 GMT+01:00 Fabio Mirotti <mirof a comune.modena.it>:
> Ciao,
>
> Sto facendo alcune prove di migrazione da plone 4 a plone 5 su un piccolo
> sito che contiene solo tipi standard:
> pagine e news, l'unica particolarita' e' che diverse pagine contengono
> elementi correlati.
>
> Non sono installati prodotti particolari, l'unico utilizzato e'
> eea.facetednavigation.
>
> Anche lo skin e' sunburst di base l'unica personalizzazione e' il cambio del
> logo applicato alla custom.
>
> Questo scenario dovrebbe essere il piu' tra i piu' semplici per effettuare
> una migrazione ma sto trovando qualche problema.
>
> In particolare quello che ho fatto e' stato:
>
> - aggiornare il sito vecchio alla 4.3.11 -- OK
> - aggiornare eea.facetednavigation alla 10.0 -- OK
> - prepararmi un buildout fresco plone 5.0.6 -- OK
> - con la stessa versione di facetednavigation -- OK
> - copiare Data.fs e blobstorage -- OK
> - avviare plone 5 -- OK
> - lanciare upgrade di configurazione -- OK
> - migrare i contenuti da AT a dexterity -- OK
>
> e fino qui tutto OK, i contenuti sono a posto, anche gli elementi correlati
> sono stati migrati correttamente.
>
> Pero' a livello di interfaccia mi trovo alcune cose che non mi tornano...
>
> Ad esempio:
> - la gestione delle portlet e' rimasta quella di plone 4, non posso gestire
> le portlet del footer.
> - il footer e' rimasto quello vecchio...
> - faceted non funziona perche' non carica jQuery.bbq che a quanto pare non
> viene aggiunto al bundle dei javascript...
>
> Naturalmente se faccio un sito nuovo sulla stessa istanza funziona tutto
> correttamente, avevo anche provato ad esportare e
> reimportare i contenuti, pero' in questo modo mi vanno in errore i
> relatedItems che sono presenti in diverse pagine del sito :(
>
> La domanda.... c'e' un qualche modo vi a ZMI di eliminare del tutto il
> registro di configurazione che si e' portato dietro in fase di migrazione
> e fargli prendere quello del plone 5 di default? Altri consigli utili per la
> migrazione?
>
> Grazie per l'aiuto.
>
>     ---Fabio
>
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-plone-it
> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



-- 
Luca Fabbri
Developer

>_
abstract.it - +39 0810608213
...............................................................................
Registro Imprese di Napoli 788429 / Cap. Soc. 10.000 Euro I.V.
Avvertenze Legali - D. Lgs. 196/03 Tutela dei dati personali. Le informazioni
contenute in questo messaggio e in ogni eventuale allegato sono riservate e
ne  vietata ogni forma di diffusione. Se avete ricevuto questa comunicazione
per errore, Vi preghiamo di informare immediatamente il mittente del messaggio
e di eliminare l'e-mail.


Maggiori informazioni sulla lista Plone-IT