[Plone-IT] EasySlideShow

Luca Fabbri keul a redturtle.it
Lun 12 Gen 2015 12:45:42 UTC


2015-01-12 13:13 GMT+01:00 Di Massa  Guerrino <guerrino.dimassa a uniupo.it>:
> In effetti uso
>
> Products.CacheSetup
>
> nel buildout.cfg
>

Non avresti bisogno usarlo su Plone 4, che offre il più moderno
plone.app.caching. Non sto a consigliarti di rimuoverlo ora... mi
sembra eccessivo se fino ad ora ha funzionato come ti aspetti (se
volessi rimuoverlo: vedi risposta di Lorenzo).

Non saprei aiutarti oltre perché non ho mai usato CacheFu su Plone
4... ma dal link che ti ho mandato pare un suo problema... forse una
versione superiore da usare?

Buona fortuna!



>
> ----- Messaggio originale -----
> Da: "Di Massa Guerrino" <guerrino.dimassa a uniupo.it>
> A: "La lista degli italiani appassionati di Plone." <plone-plone-it a lists.plone.org>
> Inviato: Lunedì, 12 gennaio 2015 13:04:49
> Oggetto: Re: [Plone-IT] EasySlideShow
>
> Plone 4.0.5
> Zope 2.12.17
>
> Di CacheFu non ne ho mai sentito parlare. Non mi risulta installato tra i rpodotti aggiuntivi.
>
> Posso darti qualche altro dettaglio?
>
> Grazie per l'assistenza.
>
> guerrino
>
>
> ----- Messaggio originale -----
> Da: "Luca Fabbri" <keul a redturtle.it>
> A: "La lista degli italiani appassionati di Plone." <plone-plone-it a lists.plone.org>
> Inviato: Lunedì, 12 gennaio 2015 12:57:08
> Oggetto: Re: [Plone-IT] EasySlideShow
>
> Ma è un Plone 3 o stai usando CacheFu su un Plone 4?
> https://dev.plone.org/ticket/10431
>
>
>
> 2015-01-12 12:54 GMT+01:00 Di Massa  Guerrino <guerrino.dimassa a uniupo.it>:
>> Ok.
>> Vediamo se ho capito.
>> Lancio il comando-> ./bin/zeoserver start
>> e poi-> ./bin/client1 fg (anche client2 andrebbe bene)
>> Risultato?
>>
>> eccolo:
>>
>> ----------------
>>
>> ./bin/client1 fg
>> 2015-01-12 12:49:10 INFO ZServer HTTP server started at Mon Jan 12 12:49:10 2015
>>         Hostname: 0.0.0.0
>>         Port: 8080
>> 2015-01-12 12:49:10 INFO Zope Set effective user to "plone"
>> 2015-01-12 12:49:11 ERROR Application Could not import Products.CacheSetup
>> Traceback (most recent call last):
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/OFS/Application.py", line 596, in import_product
>>     product=__import__(pname, global_dict, global_dict, silly)
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/__init__.py", line 10, in <module>
>>     from content import *
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/content/__init__.py", line 1, in <module>
>>     import cache_tool, caching_policy_manager
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/content/cache_tool.py", line 51, in <module>
>>     from Products.CacheSetup.interfaces import ICacheTool
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/interfaces.py", line 2, in <module>
>>     from Interface import Interface as OldInterface
>> ImportError: No module named Interface
>> Traceback (most recent call last):
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/Zope2/Startup/run.py", line 56, in <module>
>>     run()
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/Zope2/Startup/run.py", line 21, in run
>>     starter.prepare()
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/Zope2/Startup/__init__.py", line 87, in prepare
>>     self.startZope()
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/Zope2/Startup/__init__.py", line 264, in startZope
>>     Zope2.startup()
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/Zope2/__init__.py", line 47, in startup
>>     _startup()
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/Zope2/App/startup.py", line 57, in startup
>>     OFS.Application.import_products()
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/OFS/Application.py", line 573, in import_products
>>     import_product(product_dir, product_name, raise_exc=debug_mode)
>>   File "/usr/local/Plone/buildout-cache/eggs/Zope2-2.12.17-py2.6-linux-i686.egg/OFS/Application.py", line 596, in import_product
>>     product=__import__(pname, global_dict, global_dict, silly)
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/__init__.py", line 10, in <module>
>>     from content import *
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/content/__init__.py", line 1, in <module>
>>     import cache_tool, caching_policy_manager
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/content/cache_tool.py", line 51, in <module>
>>     from Products.CacheSetup.interfaces import ICacheTool
>>   File "/usr/local/Plone/buildout-cache/eggs/Products.CacheSetup-1.2.1-py2.6.egg/Products/CacheSetup/interfaces.py", line 2, in <module>
>>     from Interface import Interface as OldInterface
>> ImportError: No module named Interface
>>
>> ------------
>>
>> Esoteric error?
>>
>> :-(
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> ----- Messaggio originale -----
>> Da: "Luca Fabbri" <keul a redturtle.it>
>> A: "La lista degli italiani appassionati di Plone." <plone-plone-it a lists.plone.org>
>> Inviato: Lunedì, 12 gennaio 2015 12:39:44
>> Oggetto: Re: [Plone-IT] EasySlideShow
>>
>> 2015-01-12 12:37 GMT+01:00 Di Massa  Guerrino <guerrino.dimassa a uniupo.it>:
>>> Trattandosi di un zeocluster non riesco ad avviarlo in debug mode.
>>>
>>
>> Intendevo in foreground... Tieni attivo lo zeoserver ed avvi in
>> modalità "fg" l'istanza.
>>
>>> L'errore dell'homepage è questa:
>>>
>>> Site Error
>>> An error was encountered while publishing this resource.
>>>  ('object.__new__(SlideshowDescriptor) is not safe, use Persistence.Persistent.__new__()', , (, , None))Traceback (innermost last): Module ZPublisher.Publish, line 237, in publish_module_standard Module zope.publisher.skinnable, line 47, in setDefaultSkin Module ZODB.Connection, line 838, in setstate Module ZODB.Connection, line 906, in _setstate Module ZODB.serialize, line 629, in setGhostState Module ZODB.serialize, line 622, in getState Module copy_reg, line 48, in _reconstructor TypeError: (see above)
>>>
>>> Come la vedi?
>>>
>>
>> La vedo che forse il foreground aiuterebbe :)
>> Probabilmente l'istanza non partirà neanche e vedrai l'errore.
>>
>> Ma hai disinstallato il prodotto prima di rimuoverlo dal buildout?
>>
>>
>>>
>>> grazie ancora
>>>
>>>
>>>
>>>
>>> ----- Messaggio originale -----
>>> Da: "Luca Fabbri" <keul a redturtle.it>
>>> A: "La lista degli italiani appassionati di Plone." <plone-plone-it a lists.plone.org>
>>> Inviato: Lunedì, 12 gennaio 2015 12:12:04
>>> Oggetto: Re: [Plone-IT] EasySlideShow
>>>
>>> 2015-01-12 12:02 GMT+01:00 Di Massa  Guerrino <guerrino.dimassa a uniupo.it>:
>>>> Ciao lista e buon 2015 a tutti.
>>>> Ho installato ,per fare delle prove, questo prodotto di sixfeetup.
>>>> L'ho disinstallato dal portal_quickinstall sembra tutto ok.
>>>> Poi però togliendo dal buildout.cfg la relativa eggs di riferimento e ricompilando
>>>> appena accedo al sito mi spara fuori un bellissimo errore...
>>>> Sembra proprio che abbia sporcato qualcosa!
>>>>
>>>> Qualche idea?
>>>>
>>>> grazie come sempre e spero questa mia segnalazione possa essere di aiuto alla community!
>>>>
>>>
>>> Ciao
>>>
>>> Che errore?
>>>
>>> Hai provato con l'avvio in debug mode?
>>>
>>>
>>>
>>>> --
>>>> Guerrino Di Massa - Assistente Laboratorio Informatico - Tutor ECDL
>>>> tel:  (+39) 0321 375 504
>>>> Dipartimento di Studi per l'Economia e l'Impresa
>>>> Via Perrone, 18 - 28100 Novara
>>>> Universita' degli studi del Piemonte Orientale "Amedeo Avogadro"
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> Plone-IT mailing list
>>>> Plone-IT a lists.plone.org
>>>> https://lists.plone.org/mailman/listinfo/plone-plone-it
>>>> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
>>>
>>>
>>>
>>> --
>>> Saluti/Regards
>>>
>>> Luca Fabbri - RedTurtle Technology
>>> E-mail: luca.fabbri a redturtle.it
>>> Web Site: http://www.redturtle.it/
>>> Phone: +39 0532 1915958
>>> Fax: +39 0532 287070
>>> _______________________________________________
>>> Plone-IT mailing list
>>> Plone-IT a lists.plone.org
>>> https://lists.plone.org/mailman/listinfo/plone-plone-it
>>> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
>>> _______________________________________________
>>> Plone-IT mailing list
>>> Plone-IT a lists.plone.org
>>> https://lists.plone.org/mailman/listinfo/plone-plone-it
>>> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
>>
>>
>>
>> --
>> Saluti/Regards
>>
>> Luca Fabbri - RedTurtle Technology
>> E-mail: luca.fabbri a redturtle.it
>> Web Site: http://www.redturtle.it/
>> Phone: +39 0532 1915958
>> Fax: +39 0532 287070
>> _______________________________________________
>> Plone-IT mailing list
>> Plone-IT a lists.plone.org
>> https://lists.plone.org/mailman/listinfo/plone-plone-it
>> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
>> _______________________________________________
>> Plone-IT mailing list
>> Plone-IT a lists.plone.org
>> https://lists.plone.org/mailman/listinfo/plone-plone-it
>> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
>
>
>
> --
> Saluti/Regards
>
> Luca Fabbri - RedTurtle Technology
> E-mail: luca.fabbri a redturtle.it
> Web Site: http://www.redturtle.it/
> Phone: +39 0532 1915958
> Fax: +39 0532 287070
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-plone-it
> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-plone-it
> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html
> _______________________________________________
> Plone-IT mailing list
> Plone-IT a lists.plone.org
> https://lists.plone.org/mailman/listinfo/plone-plone-it
> http://plone-regional-forums.221720.n2.nabble.com/Plone-Italy-f221721.html



-- 
Saluti/Regards

Luca Fabbri - RedTurtle Technology
E-mail: luca.fabbri a redturtle.it
Web Site: http://www.redturtle.it/
Phone: +39 0532 1915958
Fax: +39 0532 287070


Maggiori informazioni sulla lista Plone-IT